HDMI not functionnal fresh install.

Hi all,
Just install OpenSuse Leap 42.2 on my new laptop (Dell Inspiron 15 7567 Gaming). I am unable to make my screen work through HDMI. I know for fact that its not a hardware problem because It got detected automatically when it booted on Windows when I received the computer.
When installing the OS I realized that the brightness also did not work properly so I update the Kernel and now the brightness is working, the laptop screen is also detected properly now since I update the Kernel.
I have made multiple attempt to fix this and had to reinstall multiple time and I am now running low on options/alternatives so I need your help.
Here is what I can tell you on my system

$~>xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.01*+  47.10  
   1400x1050     59.98  
   1280x1024     60.02  
   1280x960      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   800x600       60.00    60.32    56.25  
   700x525       59.98  
   640x512       60.02  
   640x480       60.00    59.94  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
DP-1 disconnected (normal left inverted right x axis y axis)

$~> cat /etc/os-release NAME="openSUSE Leap"
PRETTY_NAME="openSUSE Leap 42.2"

$~> /sbin/lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
	Subsystem: Dell Device [1028:0798]
	Kernel driver in use: i915
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1c8c] (rev a1)
	Subsystem: Dell Device [1028:0798]
	Kernel module: nouveau

Here is what I tried so far:

  • I tried updating the Graphic card driver to have the latest
  • I tried updating the BIOS.
  • I tried updating the Kernel to 4.11 (This is what enable the brightness on and off and with this install + BIOS update from scratch there is a flicker on my laptop screen when I connect the HDMI, otherwise nothing).

Right now I have another laptop similar which is a Dell Inspiron 15 7559 and on this laptop the HDMI work fine with OpenSuse installed vanilla. Also when I do the xrandr -q command on my Dell 7559 I get HDMI-1 instead of DP-1. Would that be a lead to find my problem?
Any help is mostly welcome because its been already 5 day that I have my new laptop and I am eager to let my other one go.


Since you already have Microsoft Windows out of the box, were you aware of Microsoft recovery partitions and UEFI when you went ahead and installed openSUSE Leap 42.2? New laptops are preinstalled with Windows often with a reason in mind: it is the most idiot proof operating system and regardless of how we screw them up, the recovery partition can salvage a lot of the changes. From a linux enthusiast’s perspective, now that you have “broken” your laptop, this sounds like bad news to support but good news for learning.

Before you continue, please be reminded that GNU GPL licenses are public, free and open-source software licenses. Unlike proprietary softwares such as MS Windows which come out of box with tech support guaranteed, Microfocus does not guarantee us that every single feature on openSUSE 42.2 works. Since every machine is designed differently by different vendors, your last and imho best resort is speaking with a Dell customer support on which Linux distribution works best on their machines. You paid them, it is their jobs handling your enquiries.

From my perspective as an openSUSE end user, what you are experiencing seems perfectly sane and rational. Dell machines are cranky, and either you purchase them without the Windows OEM OS - it was once an option opting out of OSes from laptops till server racks - or since you have paid good money over a Windows license, imho get it reinstated, put in Sun Virtualbox or VMWare Workstation, and you can test openSUSE as a virtual machine till you figure out more.

You have 2 Graphics cards Intel and NVIDIA this hardware is known as Optimus and is a pain on Linux

First if you installed the regular NVIDIA driver remove it then follow instructions here exactly any question ask them here


You must remove the NVIDIA driver before installing Bumblebee

Tnx for the reply, I tried a few combination that are mention on the link you mention. At some point I am able to see the option for NVIDIA and I am able to see the screen mirror on the other screen. But am unable to have two different display.
What would be the combination you would recommend to install? Uninstall NVIDIA, install Bumblebee? Install NVIDIA Driver? Leap? Tumbleweed?
I also found out that the machine is made in a little funky way. The laptop screen is using the Intel card and the HDMI port is on the NVIDIA card. It appear that opensuse or the driver has hard time handling a situation like this.

I’m afraid this is true for most Optimus machines, there are a few rare exceptions, but those are older designs, newer machines are all the same way as your.
Maybe prime can solve it, I don’t have an Optimus system myself today.
Othervise there’s the possibility to solve it by dual boot for the HDMI output, but try prime first.