HDMI audio Nvidia GTS 450

Hi,

I have a Nvidia GTS 450 GPU with HDMI. I want to have the audio on my TV that’s connected with HDMI cable. But for some reason I’m not able to get the audio working. The card has its own audio chip. In Yast and pulseaudio I can see the card. But when I select it for playing audio it will not play on my TV.

Changing the cable doesn’t work and don’t know what to do. Every thing on the internet I have tried doesn’t work. Is there someone how can help me?

Here are some settings (if you need more just ask):
Using openSuSE 11.4


cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7f78000 irq 21
 1 [NVidia_1       ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbefc000 irq 16


aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, ALC1200 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia_1,DEV=0
    HDA NVidia, HDMI 0                                                                                                                                                               
    HDMI Audio Output                                                                                                                                                                
hdmi:CARD=NVidia_1,DEV=1                                                                                                                                                             
    HDA NVidia, HDMI 0                                                                                                                                                               
    HDMI Audio Output                                                                                                                                                                
hdmi:CARD=NVidia_1,DEV=2                                                                                                                                                             
    HDA NVidia, HDMI 0                                                                                                                                                               
    HDMI Audio Output                                                                                                                                                                
hdmi:CARD=NVidia_1,DEV=3                                                                                                                                                             
    HDA NVidia, HDMI 0                                                                                                                                                               
    HDMI Audio Output


THNX
Daniël

I don’t have an HDMI setup so I can’t offer much in the line of advice, other than suggest you install pulse audio volume control app (pavucontrol) and then the 1st time you go to use any multimedia player, launch pavucontrol, and use its various configure, output device, and playback tabs to tune that application with HDMI with pulse. Do not forget in tab output device under SHOW to show all output devices, and under the playback tab SHOW to select all streams.

If that does not work, you can take a look at this post: connect Toshiba x205 laptop to TV with HDMI (solved)

Both don’t work.
The pulseaudio one I had done myself.
And the solution of the Toshiba is for old style HDMI in the new FEMI cores this was fixed as far as I know…

So my card is in pulseaudio and can be selected. But there is no sound.
If I run speaker-test -c 2 -r 48000 -D hw:1,3 It starts shows the same thing as when I’m doing it to my normal soundcard but again no sound.

Does it help?

I found the following link where another person said to get it to work.

No Audio with Nvidia GTS 450

Let me tell you that I have tried this on a nVIDIA GTS 240 and found that while you can get stereo to work, I could never get Dolby Digital to work, not even in Windows where my Sony 5.1 receiver told me I had Dolby Digital 2/0, which is basically stereo. If you want to know my opinion, I would use the computer built-in audio and forget about the HDMI audio from this video card. I have an HTPC setup with a nVIDIA GTX460 video card and I just use the built-in PC optical audio out taken straight to my Sony 5.1 Receiver. My LG TV does also includes optical and Coax audio input, but I just took out the analog stereo audio out form the built-in motherboard audio to the TV if I wanted to hear standard sounds without turning on the Sony Receiver. I say give up on HDMI and find another way.

Thank You,

The fix there reminded me of post#20, #21, and #22 in this openSUSE thread: Sound to multiple output devices with pulse?
… slightly different but it still may be of help

Nope didn’t work. Made it even worse (no audio at all).

I do have playback. If I switch to the HDMI-output The bar starts moving in the output device tab of the pavucontrol. But there is no audio on my TV.

In ALSAmixer I’m not able to raise the volume of the lines on the sound card… I’m able to mute them.

So it’s like the sound doesn’t reach my TV at all.

Out of curiosity, with your HDMI output connected and setup the way YOU think is best, run the diagnostic script:


/usr/sbin/alsa-info.sh

and select the share/upload option to upload the output to the internet/alsa paste site and post here the website-address/url that the script will give when after it is 100% complete.

If you have no internet access to do this, then run the script with the no upload option:


/usr/sbin/alsa-info.sh --no-upload

which will create a file in /tmp/alsa-info.txt and copy that file’s contents and paste it to SUSE Paste and submit it there and again post here the website/URL address where the output is located.

Also provide screen prints of your pavucontrol gui settings (config, output-devices, and playback, ensure you have SHOW selected properly in those tabs as applicable) and also the contents of ANY config files that you may have edited. If the files are too big then paste their contents on SUSE Paste and post here the website/URL address where the file contents are located.

The output of alsa-info.sh is Here.

A reset of the pulseaudio files and a reboot fixed the problem with no audio at all. So I do have sound again.

I have sound when I run: speaker-test -D hw:1,7 -c 2 /dev/urandom
The 7 first was a 3 That use to be the only that didn’t produce an error. But still now audio. I have updated /etc/pulse/default.pa.

Problem is SOLVED!!!

I found the solution while reading the output of alsa-info.sh. Alsa found two hardware profiles one on hw1,3 and one on hw1,7. Pulse only found the one on hw1,3. I forced pulse to use hw1,7 and now its fixed.

Thanks for your help you all!

Well done …

Based on the alsa-info.sh output of this:


!!Aplay/Arecord output
!!------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1:** NVidia_1 [HDA NVidia], **device 3:** HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1**: NVidia_1 [HDA NVidia], **device 7: **HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1:** NVidia_1 [HDA NVidia], **device 8:** HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**card 1:** NVidia_1 [HDA NVidia], **device 9:** HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I probably would have asked that you try hw:1,3, hw:1,7, hw:1,8 and hw:1,9. Glad to read you found a working setting already with hw:1,7 !

Could you explain in detail how a correction - in which file and how to pulse-audio?

Do you have a problem with sound ?

Are you trying to learn more about the hw:x,y settings? If so, what is the output of the command:


aplay -l

where that is a lower case ‘L’

niki@box:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

IIn these settings I have sound only during startup of KDE!

From which device are you trying to get sound ? From the HDMI ? or from the ALC887-VD Analog ? or from the ALC887-VD Digital ?

Hello…

I also have problem with HDMI. My computer has another sound output from the motherboard. Sound working fine from that.
Recently I am using my LCD TV as a replacement of my old monitor. I am using HDMI cable from my graphic card (NVIDIA GT 440) to LCD TV.
I tried with pavucontrol, I can see the slide moving if i use HDMI output sound but no sound come from my TV.

Here is the link for my alsa information:
http://www.alsa-project.org/db/?f=3bd6bb3614523674fe350eacf73eb9aeeba57e59

And here is the output for aplay -l :

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 7: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 8: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: NVidia_1 [HDA NVidia], device 9: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Any idea to make it work? Any help would be appreciated. Thanks.

Bimo

ok, so you have

  • hw:0,1
  • hw:0,3
  • hw:1,3
  • hw:1,7
  • hw:1,8
  • hw:1,9

Can pulse see all of those ? If so, did you try all of them (one at at time) in pavucontrol ?

Note I do NOT currently have an HDMI hardware setup nor I have ever had a functional HDMI hardware setup with sound. … I’m just trying to help/ensure you were thorough in this .

Thanks for the reply.

I uploaded my pavucontrol output devices in ImageBam - Fast, Free Image Hosting and Photo Sharing

Internal Analog Audio Stereo, Port section has two choices

  1. Analog speaker
  2. Analog output.

I also uploaded pavucontrol coniguration tab in ImageBam - Fast, Free Image Hosting and Photo Sharing

Internal Audio, Profile tab has 8 choices:

  1. Analog Stereo Duplex
  2. Analog Stereo Output
  3. Digital Stereo (IEC958)Output + Analog Stereo Input
    4 Digital Stereo Duplex (IEC958)
  4. Digital Stereo (HDMI) Output + Analog Stereo Input
    6 Digital Stereo (HDMI) Output
  5. Analog Stereo Input
  6. Off

GF108 High Definiton Audio Controller, Profile tab has 2 choices:

  1. Digital Stereo (HDMI) output
  2. Off

Based on that, i think pulse has not see all of hw:01–hw:1,9 ? Is that correct?

I tried toplay again with pavucontrol and now my VLC sound stop working after around 10 minutes play but Kaffein works fine. Is there any relation with what i do , changing configuration in pavucontrol and i forget to turn in back to correct setting?

Once again, thanks for your help.

Bimo

For the VLC part , I solved the problem, I change Preference → Audio → Output Module to Default, and it working nicely now.

HDMI part still not working.

Thanks again.

Does that mean your HDMI sound works and you only have a problem where sound stops in VLC every now and then ? Did you trying changing the output audio mode in VLC to OSS ?

I don’t understand the question.