HDMI audio not in sound manager


I have recently added a Zotac Zone 240 (Nvidia) card in my system replacing a Nvidia 7600 card.

What I have noticed is that I cannot play audio over HDMI. The Zotac audio hardware is detected by openSuse 11.2 but the KDE Sound does not show this Nvidia/HDMI sound as a possible audio device.

Please let me know how to add it as the normal add and look for device option does not have this specific Nvidia audio device as an option to add.

Now this is a shot in the dark, but you might install Kaffine/KDE3 version, if you have not already done so. Then, in Kaffine pick the XINE (Settings>xine Engine Parameters), On the left select Audio. Next, on speaker output, pick passthrough and see if that does anything for you. You can also play with the driver, but try Auto first.

Thank You,

First let me say I know next to nothing about HDMI audio, as we never did get the HDMI audio working with my laptop (that has this HDMI capability) nor with my relatively new PC (that also has this HDMI capability). Mind you I have not tried for over 15 months with the laptop and never tried with the new PC as I don’t have anything to test it with.

Still, you could provide more information. Please do so by following the guidance given in our multimedia stickie:
Welcome to multimedia sub-area - openSUSE Forums

In particular, please provide the information needed for guidance from the 2nd half of that stickie, and I quote:

please post … the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/alsa-info.sh and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Hi all,

Thanks for the responses but I really needed this to work so as I had an extra Windows 7 license I replaced openSuse for. I am actually quite sad as it was running perfectly except for the HDMI audio and no easy way to find usable possibilities.

After 11.3 is released I am hoping that someone using HDMI audio can let me know if, in essence, this works out of the box.

I can tell you now that HDMI works in openSUSE-11.1 for some users, and not others. Everyone’s hardware is different, and the behaviour is different for everyone’s hardware, so unless you get really lucky and a user with the EXACT same hardware as you happens to post, its rather unlikely you will ever get this answer. IMHO the only reliable way to find out is to test yourself.