HDMI Audio broken On Nvidia GPU

I recently purchased a new system build with a Asus TUF Gaming Z790 Plus Wifi motherboard/ Core I7-13700k CPU/ 32gb Corsair platinum DDR5 6200mhz ram / Gigabyte Geforce RTX 4080 OC Graphics. On my old 1070TI I never had an issue with HDMI audio, but on this one Ive been having a lot of issues. It appears HDMI2 audio is the one plugged in but I get no sound from it no matter whats playing.

So I found in the Nvidia control panel that the driver is using the wrong device, instead of my TV its using my HP monitor (that doesnt even have speakers) not sure how to fix this.

What audio sinks are reported by the following command?

wpctl status 

Also, can you provide the NVIDIA graphics driver version (just in case that is relevant here)?

inxi -Ga

I have a similar issue with Nvidia 4080, audio device doesn’t show up in the plasma5-pa, speaker-test is unable to play any sound using the device.

Some debuggind data

inxi -Aa

Audio:
  Device-1: Intel vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:7a50
    class-ID: 0403
  Sound API: ALSA v: k6.2.9-1-default running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes

wpctl status (omitted some irrelevant parts for brevity)

PipeWire 'pipewire-0' [0.3.67, nyrkovalex@localhost.localdomain, cookie:248439476]
 └─ Clients: ...

Audio
 ├─ Devices:
 │      43. Built-in Audio                      [alsa]
 │  
 ├─ Sinks:
 │  *   49. Built-in Audio Analog Stereo        [vol: 0.40]
 │  
 ├─ Sink endpoints:
 │  
 ├─ Sources:
 │  *  128. Built-in Audio Analog Stereo        [vol: 0.30]
 │  
 ├─ Source endpoints:
 │  
 └─ Streams:

Video ...

Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    bluez_output.C8_7B_23_56_34_5F.1

cat /proc/asound/cards

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0x6434140000 irq 203

cat /proc/asound/pcm

00-00: ALC274 Analog : ALC274 Analog : playback 1 : capture 1
00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1

There might be a relevant discussion here where they report that a newer nvidia driver (v530) fixes the issue, but I’m not 100% sure.

So just in case, here is inxi -Ga

inxi -Ga
Graphics:
  Device-1: Intel Raptor Lake-S UHD Graphics vendor: Tongfang Hongkong
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:a788
    class-ID: 0300
  Device-2: NVIDIA AD104M [GeForce RTX 4080 Max-Q / Mobile]
    vendor: Tongfang Hongkong driver: nvidia v: 525.105.17
    alternate: nouveau,nvidia_drm non-free: N/A status: unknown device ID
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    ports: active: none off: HDMI-A-1 empty: DP-1,DP-2,eDP-2 bus-ID: 01:00.0
    chip-ID: 10de:27a0 class-ID: 0300
  Device-3: Chicony FHD Webcam type: USB driver: uvcvideo bus-ID: 2-5:2
    chip-ID: 04f2:b7c2 class-ID: 0e02 serial: 01.00.00
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 6400x2160 s-dpi: 193 s-size: 844x284mm (33.23x11.18")
    s-diag: 891mm (35.06")
  Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: top-right
    model: Philips FTV serial: 16843009 built: 2021 res: 3840x2160 dpi: 68
    gamma: 1.2 size: 1440x810mm (56.69x31.89") diag: 1652mm (65") ratio: 16:9
    modes: max: 3840x2160 min: 640x480
  Monitor-2: eDP-1 pos: primary,bottom-l model: BOE Display 0x0a3b
    built: 2021 res: 2560x1600 hz: 240 dpi: 189 gamma: 1.2
    size: 344x215mm (13.54x8.46") diag: 406mm (16") ratio: 16:10
    modes: 2560x1600
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: Mesa Intel Graphics (RPL-S)
    direct render: Yes

Do you have a pro audio present in your pavucontrol (volume control) configuration?
On my nvidia rtx 3050 it is using pro audio in tumbleweed instead of the HDMI’s in the configuration profile.

Hey, thank you for replying. I do have this profile, but it doesn’t seem to work for HDMI – it won’t play anything no matter which output I select unless it’s a laptop speaker

@ nyrkovalex, In the pavucontrol configuration profile, are the HDMI’s listed as unplugged or unavailable?
If it’s not it might just been muted.
Try running alsamixer in the terminal then press F6 and choose the nvidia soundcard to see the status.
If it is muted you will see “MM” if it is not you will see “00”

It is not listed there at all, and alsamixer only shows a single sound card with no HDMI output.

I believe having a single card there is correct since /proc/asound/pcm shows hdmi to be available on card 0.

UPD just reread an OP’s message and it looks they might have a different problem