hdd local repo

Guys leaving the discussion is this logical or not.
If I download the whole www folder to my hdd
for example:

and replace in package manager source

with local one
will this work as it works from http server?

What i want to do is to backup chosen repos before my linux release will be not supported anymore.

Marek <cygi>

The first mistake is there, if what you post is correct: you run 11.1 according to your signature, you downloaded the 11.2 repos. The top one is will use only what you have on a DVD already.
Are you also going to download the entire Packman repo, all the KDE4, Gnome repos?

Maybe things will become more easy if you start looking around in Yast’s Software installer and repo manager. The repo manager f.e. offers an option to add a local directory as a repo.

Another suggestion: if you’re so dedicated to this version, these packages etc, see that you make a disk image copy of your root.

you are correct I run 11.1 but 11.2 or 11.1 was just an example.

Image of root is not enough. There are still some packages that I don’t need at the moment but maybe will use in the future.

I bought a 500 GB disk should be enough to dump several repos (Oss, NonOss, Packam etc.)

I wonder is the structure of the http repo universal I mean there are just a files which copied to another directory act in the same manner.


OK I have tried to make just a copy of www folder and it works perfectly.

Now I have a new challenge now.
How to make a copy of www folder automatically.

I have tried diff. soft like Offline Browsers and File Download Managers (teleport, download the all, httrack … and many others)
If you visit this web page Index of /repositories/Apache/openSUSE_11.1
you will see files directory with sub-folders

If downloading files file by file manually and re-constructing folder’s tree manually on my hard drive, created “mirror” works perfectly.
the problem is that the files list we see on-line in a web-browser is not a listing of files in a directory. It is a html web page with such a listing.
So downloading this web site copies a lot of rubbish.
Many html files, metalink web-pages, strange files etc.
I don’t need them.

I just want to have an off-line copy of files structure that is presented by the repo www serwer for my on-line web browser.
Any good idea how to download such a web folder with repo to my disk?

Marek <cygi>

I’d use rsync.

Nice to know thanks. I didn’t know that there is a protocol like this :smiley:

Now the new challenge …

how to use rsync.
I tried 2 sets of commands:

rsync -P -v -r download.opensuse.org/repositories/Apache/openSUSE_11.1/ .

from a web page

rsync -r -a -v -e --delete download.opensuse.org/repositories/Apache/openSUSE_11.1/ .

from a web page:
How to use rsync for transferring files under Linux or UNIX

Everytime the result is more less like this:

sending incremental file list

sent 42 bytes  received 15 bytes  114.00 bytes/sec
total size is 0  speedup is 0.00

If somebody could provide me how to download, will be very glad.

You seem to be missing the target directory

Generally you would need a target and a source directory

Actually target is there - current folder (./)
Anyway it seems that opensuse.org does not support rsync

I found that command

rsync ftp.nluug.nl::


rsync download.opensuse.org::

does not:

rsync: failed to connect to download.opensuse.org: Connection refused (111)
rsync error: error in socket IO (code 10) at clientserver.c(122) [receiver=3.0.4]

Any ideas?

Just found a mirror with rsync supp.
Little bit diff folder structure but this should do for me.
LeaseWeb mirror | Index of /opensuse/

 rsync mirror.leaseweb.com::opensuse/
 _____   _______ _______ _______ _______ ________ _______ ______
|     |_|    ___|   _   |     __|    ___|  |  |  |    ___|   __ \
|       |    ___|       |__     |    ___|  |  |  |    ___|   __ <

                   -= LeaseWeb mirror server =-

Welcome to mirror.leaseweb.net:
This server is located at Evoswitch DC, Haarlem, The Netherlands, and
is running on a 2GE connection with approximately 11 TB storage.

We currently offer various methods to access mirror.leaseweb.net.
At present we support http, ftp and rsync. All 3 methods are
available in both IPv4 and IPv6.

HTTP  [http://mirror.leaseweb.net]
FTP   [ftp://mirror.leaseweb.net]
RSYNC [rsync://mirror.leaseweb.net]

mirror.leaseweb.net should resolve to the correct IP version for you,
but you can force selection by using mirror.ipv4.leaseweb.net or

DISCLAIMER: LeaseWeb is not liable for any use, storage or transmission
of any files stored on this archive. We are unable to check all files 
for virus infections because much of our archive is mirrored from other 
servers. Please proceed with caution.

If you have any problems or comments about this archive, please send
them via e-mail to mirror_at_leaseweb_dot_com. Please also let us know
if there is something we don't have that you think we should!

drwxr-xr-x        4096 2010/08/09 10:02:35 .
-rw-rw-r--          11 2010/08/09 10:02:34 TIME
-rw-rw-r--          29 2010/08/09 10:02:34 timestamp.txt
drwxr-xr-x        4096 2010/08/09 10:00:01 distribution
drwxr-xr-x        4096 2008/10/18 11:30:26 factory
drwxrwxr-x        4096 2010/08/09 10:02:34 project
drwxr-xr-x        4096 2010/07/31 00:55:00 repositories
drwxr-xr-x        4096 2010/07/12 11:50:01 update

On 2010-08-09 19:36, cygi wrote:
> Actually target is there - current folder (./)
> Anyway it seems that opensuse.org does not support rsync

You just have to look up the list of mirrors, it lists what protocols supports each one.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” GM (Elessar))