HD 4870 drivers opensuse 11.2 (64bit)

Hello everyone, after countless attempts at installing suitable drivers with the guides i’ve read on this site, I hav eno choice but to beg for assistance.

I cnanot enable compiz. I would like to use the opensource drivers for my card because i have bad experiences with fglrx on linux. maximising and minimising tends to lag. I recently distrohopped from LInuxmint, and the drivers taht came packaged with it worked perfectly for me with compiz etc. I’d like the same for opensuse.
I tried the radeon driver guide, using sax2 or something like that…it failed.
I tried installing the Xorg ones and that didn’t work out among a good few others. I’m exhausted now.

ON a side note if i wanted to remove opensuse including grub and restore my pc to teh way it was before linux, how do i go about that?

ok, do this:
go to amd.com, and download the current catalyst driver for linux. run the installer as root. when it’s done, run this command as root:

aticonfig --initial -f


If you’re on 11.2, the requirement to get a working opensource radeon driver that can support 3D with compiz is to get the latest X server and preferably kernel 2.6.34 (those are available in the repos). But since 11.3 is almost out and I believe it should work well with your HD 4870, you might want to try the latest RC instead and wait for the final release.

First, sorry to read of your frustration.

IMHO neither the radeon nor the radeonhd drivers in openSUSE-11.2 as packaged work well for special desktop effects. As noted by michael_cheah, there are improvements in the Radeon Drivers that you will see in openSUSE-11.3. For example, on my Dell Studio 1537 laptop with an HD3450, on 11.3 RC2 I see a massive improvement with special desktop effects and the open source radeon driver (although it does NOT have the performance of the FGLRX proprietary driver).

However having typed that, my experience an on ATI Radeon 9200 pro is even in 11.3 (based on an assessment of RC1) the radeon and radeonhd drivers are NOT as good as those in, for example, in the latest Fedora-13, and possibly not as in the latest Ubuntu releases. Definitely Fedora are applying patches for Radeon and Radeonhd that are not yet accepted upstream (and hence have not made it downstream to openSUSE), and I suspect the same is true for the latest Ubuntu based distributions.

This is not an issue for me, as I typically switch OFF special desktop effects, as I prefer to use the CPU cycles that they consume for other CPU intensive activities (such as multimedia rendering).

“something like that” ?? Note your options are radeon and radeonhd driver, where the support for the radeonhd driver is being reduced in favour of the radeon driver. Also, if you do try 11.3, the configuration wizard sax2 is being dropped.

What are ‘the Xorg ones’ ?? Note you will NOT get special desktop effects from the FBDEV nor the VESA driver.


I am having issues too. I downloaded the latest drivers from AMD and I ran the installer from a terminal, I selected the 1st option, cant remember wehat its called but it wasnt the one to create a distro specific driver then ran the aticonfig --initial command but the video performance is super poor. The driver ios defo installed and the fglrx drivers are in use but I cant even scroll a simple web page or drag a window because of the amount of tearing and lag. It looks and feels like its using thee most basic of drivers, im sure its justa config issue but I have no idea what to do, could someone help pls?

Managed to get drivers much more stable by adding the ati repos and installing driver via yast. Its defo better but a thing I noticed with the vesa drivers which i hoped would be gone in the ati drivers is that the windows have a tracing effect when dragging, anyone know how i can stop that from happening?

what card are you using?

Hi russlar,

Its the Radeon 4870.

openSUSE Graphic Card Practical Theory Guide for Users

I followed this guide.

I also added an ATI repo from the software sources on this site. I tried a few of the 11.2 drivers they had, to see if they would work. I managed to get 3d on ONE of them, but the 2d acceleration was poor. In the software centre the drivers had Xorg in it’s name I just can’t remember exactly what they were called. What i do know is that the lag of minimising and maximising was present just like if i had fglrx. ATI’s proprietary is so annoying sigh nvidia folk don’t suffer like this.

For now i’ve removed openSUSE (which was extremely hard to do thanks to GRUB :() until i can get a hang of linux a bit better. The OS Is beautiful, but too much stress for me right now. I’ll probably wait until 11.3 comes out to dive back into it again haha. I really wish that there was a WUBI equivalent way to install opensuse. That was so convenient

I’m still unaccustomed to the slow package management system too, i’ve been spoilt by apt get and deb install, and the instant load of the package manager

My system is working great now. The trailing effect i had doesnt appear when compising is enabled, looks awesome now.

hey good for u :slight_smile:
How is maximising and minimising? is it lag free?