Have to manually bring the network card up

Opensuse factory, gnome, x64

Since few days ago, maybe a week, my second network card used for LAN isn’t up anymore, either on boot or when media connected, used to work before automatically.
Solution at the moment is to use ‘ifup enp1s1’

Once up machines can see each other and everything is working fine, but if I reboot this PC then it’s down and stays down.
Card is set to be activated on boot.

I guess it must have been some update that caused this, is there any better workaround ?

Re-inspect your network card properties using YAST, verify it really is set to start on system boot and that you don’t have the network manager service enabled.

systemctl status NetworkManager

And, if enabled, then disable

systemctl disable NetworkManager


Network manager is disabled.
I checked again and card is set to start on boot.

Actually, I think I said it wrong in the first post.
So, if 2 PC’s are connected and I reboot this PC, then everything works as it should, meaning no problems.
If other PC is shutdown and I reboot this PC then interface on this PC is down (which is normal because media is not connected), but when other PC gets turned on, interface on this PC is still down (doesn’t recognize media connected, however this worked without problems until few days ago), so I have to manually bring it up with ‘ifup’
Hope this isn’t confusing.

Basically, if interface on this PC is down (because media is disconnected (other PC is shutdown)) it will stay down when other PC is turned on.
It goes up if I manually bring it up.

I do not realy understand how a NIC connected to a LAN can even see hardware wise on it’s cable if other systems are connected to the same LAN. It only sees the router. Did you check that with a third system on the LAN? And does the NIC come up with zero, one or two of the other systems being active? When with one, makes it a difference which one?

There are no more systems and there’s no router.
Just two NIC’s connected directly.

Maybe it’s something with that other system, it probably is, I’ll recheck with other systems probably next week, it’s not a big deal, but interestingly it was working fine for years.

With a “cross” cable I presume.

Thank you for not explaining that earlier. :sarcastic:

When your system boots up, “auto sense” is typically enabled which means that the NIC is up only if it senses a device on the other end… Otherwise the NIC thinks it’s unplugged/physically unattached.

You can resolve your issue by using either a hub or switch with patch cables between your devices instead of a cross-over cable (or patch cable with NICs which auto-configure for crossover).


Yes, but the problem is that it doesn’t detect other NIC when that NIC goes up.
It does on boot, but if the other NIC goes up while this PC is already active, then it doesn’t detect it and brings it up, only manually.
And that used to work, but not anymore.

Start by watching the actual lights on your NICs.
You should not only see the lights on, but blinking indicating activity when the other machine boots.
If the lights don’t light up or indicate activity, then software is not going to work.


On Fri, 05 Sep 2014 20:56:02 GMT, hcvv <hcvv@no-mx.forums.opensuse.org>

>gzenum;2663003 Wrote:
>> There are no more systems and there’s no router.
>> Just two NIC’s connected directly.
>With a “cross” cable I presume.
>Thank you for not explaining that earlier. :sarcastic:

Auto MDX and Auto MDIX has made all that unnecessary. Just hook it up and
it should work. All part 0f 802.3 now.


I assume you’re using ‘traditional ifup’ (configured via yast). This may be impacted by your ‘STARTMODE’ perhaps. Have a look at the config file: /etc/sysconfig/network/ifcfg-<name>