Have install media created, and was ready to install, BUT then I found out my printer/scanner is not

supported by the manufacturer, or by openSuse. Bummer!
I need the print and scan capabilities, and if they don’t work, it does me little good to install any linux distro that I can’t use for things I need it for.

I have a post in the hardware section seeking help. Hopefully there will be something from someone in there that I can do to be able to print and scan.

MUlti-Function unit is a Canon ImageCLASS MF3240(a bad buy is seems now). Copy and fax are on the units panel, but print and scan are not. HEll, even the scan button on the panel doesn’t work because it need software to accept the scan. Those I have tried don’t work.

Canon does serve packages for downoad, Check for ‘canon rpm download’

I’m not sure I would use Tumbleweed for a system where the printer is critical, even if a printer driver was offered (It isn’t. I looked here: https://www.openprinting.org/printers ).

I don’t know what the specs are on your system, but please be able to restore before experimenting:

You can always run a virtual Windows system (Virtualbox, KVM, Xen, etc) and print from the virtual system.

Yup, tried that, no go for my Canon printer. Seems like Windows is their preferred area of providing drivers and support. At least for most if not all of the ImageCLASS multi functions.
Thanks for the response.

It is going to be a dual boot system anyway, but I would hate to have to leave one to go to the other just to print a form or something from a web page, or…
I did ‘live’ versions of several linux distros, and most of them actually recognize the printer as a ‘Canon MF3240’, which it is.
Just no luck getting it to print anything. I can see the queue, tell it to print them again, but all I get is a flash and no print, again.

Oh well, I guess linux was not meant to be in my future. I am old, retired, and on a limited income, and I can’t go buy another piece of equipment becasue the supplier stops supporting them after what seems to be a very short time period.
Sorry for the extended gripe, I know it is not the fault of linux nor openSuse.

BTW> why not Tumbleweed? I thought it was the better of openSuse’s and gave the best performance and chances of faster updates if and when they are available. Am i wrong?

BTW2> I’ve done VB’s before and have not been real impressed with the set up and performance of things running in them. But it is something to think about.

Thanks for the response.

I am sure I will get dinged by Tumbleweed advocates. However, it is a rolling release. You are trying to configure a non-standard printer. If you got the printer to work every zypper dup (the command used in Tumbleweed to go to the next distribution release) would possibly require you to go through the same process again to re-configure the printer.

Cannon seems pretty squirrelly on what language your printer even speaks. This leads me to believe it is proprietary.

use cannon’s rpm’s and then you have to find the ports you need to open in the firewall and open them. I use a cannon and it works very well but i had to figure out the ports and firewall problems first.

Once you have the firewall configured correctly it will work :slight_smile:

Yes I use Tumbleweed.

The scanner portion has it’s own ports along with the print function having it’s own. If I remember correctly cannon does list what ports that need to be opened on their site somewhere

I found that not that long ago, Canon changed and may still be changing how their printers interoperate so what may have worked a year ago might not be relevant today no matter what OS you are using. Even the protocol may have changed (Not very long ago Canon had their own unique and proprietary printer protocol, but the last system I set up not that long ago didn’t require that). Also, Canon may provide their own software and utilities.

Of course you should always start first with default printer apps to see if things will “just work” with support built into the Linux kernel…
If that doesn’t work, then

I’d recommend you start with the following Internet searches…
Printer model number, linux drivers support
canon linux drivers support

Of course,
Try to avoid Debian and Ubuntu solutions at first on the likelihood packes will be deb.

If you find something and run into a problem trying to install,
You can post again and be sure you include detailed errors and if necessary screenshots or camera pics of your screen.


To close this thread out, I opted for Leap, installed 42.3, then upgraded to 15.0. Regardless, my Canon MF 3240 multi is going to be a problem. Skanalite works, and I fear installing that ‘may’ be comparable will mess even that up.
I am strongly considering the VM option and putting in my old WinXP 64bit. The multi-function is/was flawless in that.

Time will tell.

I would suggest taking a look at VueScan at hamrick.com.

VueScan is a commercial scanning program so you do have to pay for it but I think it is by far the best scanning software that I’ve used. It has a native Linux version and it supports an immense range of scanners, including many scanners that are not otherwise supported on Linux. I’ve used it with two different Canon multifunction scanners and it works beautifully. VueScan is very reasonably priced and they offer a lifetime version that will be updated and supported as long as you live (it’s a father and son company, so it will probably be longer than I live). Read the New York Times and other reviews. I recommend VueScan to anyone who has a scanner. I don’t mean to make this sound like an ad and I have no connection with VueScan other than being an enthusiastic user.

[FONT=Verdana]Also,you can use VueScan on up to four different computers that you personally use, with any combination of operating systems (Windows,Mac, Linux), with any number of scanners, both x32 and x64, with a single license.[/FONT]