Hauppauge 1600

im trying to get my hauppauge 1600 working under opensuse. i downloaded the beta driver from http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.gz (the bz2 outputs python errors) and extracted it to my desktop. i su’ed and went into the folder.
i ran make menuconfig and saved the configuration (no changes to default).
make compiled without errors
make install installed without errors
make unload no errors
modprobe cx18 no output at all (expected)

then i went to /lib/firmware and was supposed to copy 3 files from the windows firmware to a $KERNEL_VERSION. this folder did no exist and when i ran echo $KERNEL_VERSION i get blank output. i tried copying the files to the root of the firmware directory and renamed them appropriately as instructed by WinTV-HVR-1600 Frequently asked questions

when i rebooted X would no start and my webcam (/dev/video0) was no recognized. after i uninstalled the driver (make rminstall) the webcam was still not recognized until i reinstalled the kernel.

does anyone know how to get the hauppauge 1600 working why my $KERNEL_VERSION has no value?

uname -a


i noticed that it said if u are getting an error go to lne 350 of the cx18-firmware.c and change the #if 0 to #if 1 but there are only 347 lines in this file

Just wondering if you ever did get your Card working

The firmware files need to go in /lib/firmware. Opensuse has one directory that every kernel version reads from instead of a firmware directory for each kernel version like Debian/Ubuntu. I followed the same guide as you for Opensuse 11 and have gotten the card to initialize at boot, but I haven’t ran the cables to the PC to make sure it works. It doesn’t show up in Yast>TV Cards though.

shawnr@fastback2:~> dmesg | grep Hauppauge
cx18-0: Autodetected Hauppauge card
tveeprom 2-0050: Hauppauge model 74551, rev C1A3, serial# 2600803
cx18-0: Autodetected Hauppauge HVR-1600
cx18-0: Initialized card #0: Hauppauge HVR-1600

On the bright side, Opensuse 11.1 beta3 already has the cx18 driver in the kernel. It still didn’t show up in the TV Card section though. I think since the driver is still a beta version for the 1600, that it probably wont show up until it goes stable. Do a Google search for Ubuntu Hauppauge 1600 to see several people who have reported success with mplayer working with it after using this guide. If you are using a Nvidia driver, there are conflicts with the cx18 module that will not let you boot. I have to use vmalloc=192M pci=nommconf as a boot option to get Opensuse to boot when using the cx18 and nvidia modules at the same time.