Has stopped supporting older smb protocols?


I have some older Buffalo NAS with oooold smb versions. Worked fine till some days ago, now I can’t access these shares from KDE/Dolphin any more, I get

Unknown error condition in stat: Software caused connection abort

while Leap 15.1 ha no problems at all. Tried from different TW installs, reboot didn’t help.

Any ideas?

How crazy is that? The world is full of Windows XP and 7 machines, supporting smb1 and even on Windows 10 you can install support for smb1.

But the linux samba guys decide to make the world a better place by deleting support for smb1, although the vulnerabilities are on the Windows part of the universe. These guys should adjust their medication…

I am not a SAMBA user, but I do not understand this.

You get an error message, but instead of trying to get help here with understandng the message and repairing things, you jump to the conclusion that it isn’t is supported anymore and then you start ranting to people who do not even visit these forums.

Either you want technical help and then provide as much technical information you can, or you post in Soapbox (but even there you are restricted in what you say).

Venting frustration here will at the most deter people to provide help.



Samba version 4.11.0-git.95.c88b5f2c0c6SUSE-oS15.5-x86_64

A short glance tell me that it talks about “on by default”. Thus find out how to switch it on (probably in one of the configuration files).

Again, I do not use SAMB, but what I say above looks as the most logical step to me.

See also this one:

I have no Windowz on these networks. Mounting the NAS in fstab is not an option, if the mount fails the machine will not boot.

I do not understand why you are switching subjects, but adding the option nofail to the fstab entry will avoid the system hang on boot when the server is unavailable.

Hmmmmm…, the final 2 posts in the thread you linked, maybe? :wink:

I did not read that whole thread. I had the vague idea that I had seen something like your problem earlier, searched for it, found it and offered you the link (something you could have done yourself btw).

… I thought anybody would provide a solution. Not small talk… :smiley:

OK, I downgraded samba-client to 4.10.4 from here


and locked it …and it works again. :wink:

Total nonsense. The use of SMBv1 (30 year old deprecated protocol) is considered a major security risk with well known vulnerabilities. However, just like with Windows 10 it can still be deliberately enabled in a Linux environment. There are numerous thread on the subject anyway. Always pays to read the release notes…


Sorry, but I don’t have the time to read the release notes of thousands of packages updated by TW over a month or so. I don’t see any options to anable for the client (!) smb1 in 4.11. Please correct me if I’m wrong.

The release notes mention

It’s still possible to allow SMB1 dialects, e.g. NT1, LANMAN2 and LANMAN1 for client and server, as well as CORE and COREPLUS on the client.
Note: that most commandline tools e.g. smbclient, smbcacls and others also support the ‘–option’ argument to overwrite smb.conf options, e.g. --option=‘client min protocol=NT1’ might be useful.

The thread Henk linked to (just one of many) discusses how to add an appropriate entry in smb.conf for clients that must connect to SMB1 (NT1 protocol) servers…

Another caveat to be aware of…

LanMan and plaintext authentication deprecated

The “lanman auth” and “encrypt passwords” parameters are deprecated
with this release as both are only applicable to SMB1 and are quite
insecure. NTLM, NTLMv2 and Kerberos authentication are unaffected, as
“encrypt passwords = yes” has been the default since Samba 3.0.0.

If you have a strong requirement for these authentication protocols,
please file a bug at https://bugzilla.samba.org and let us know about
the details.

The problem is not the server (old Buffalo NAS with smb1 only). The problem is the client.

Again, the question is:Is there an option to access via dolphin a smb1 share with 4.11 installed? I don’t see any way yet…

Yes, I got that already. The setting in smb.conf is for samba client configuration.

Again, the question is:Is there an option to access via dolphin a smb1 share with 4.11 installed? I don’t see any way yet…

Make the configuration first, then try navigating to your share in dolphin eg ‘smb://jim@nas01.local/’

I added to the end of /etc/samba/smb.conf


on the client machine.


sudo service smb restart

Makes no difference. Same error as in opening post.

Non one asked you to do that, so I’m not surprised about the result.

On all my openSUSE-clients i use a shell script to mount my NAS- shares.

Basically all the script does is

# mount.cifs SERVER-SHARE CLIENT-MOUNTPOINT -o sec=X,vers=Y,user=...

Values for X and Y can be found with

# man mount.cifs

With SAMBA Vers. 4.11.0+git.95.c88b5f2c0c6-1.1 (current openSUSE Tumbleweed)* vers* can range from 1.0 up to 3.11.

BTW it might be worth to check the Buffalo website (or the forums) for an update for your NAS-OS (my 10 year old QNAP supports higher versions than 1.0).