Has anyone got No Machine to work on 12.3?

I have scoured forums and articles and tried just about everything I can to get No Machine to work on 12.3. It works great on 11.4 but I need to upgrade real soon. I am getting the sanity check error on installing the server. I have it working on Fedora 18, but would rather have my main work box opensuse. Any help will be greatly appreciated.

Why not put “No Machine” on a LONG LIFE OS
like RHEL6

seeing as this IS a server
opensuse at 18 month life cycle is a bit TOO short
just like Fedora’s 13 month life cycle is WAY TOO short

SLES 11 or RHEL 6

it would much better to have it installed on a OS that has a ** 10 YEAR LIFE CYCLE

Hello and welcome to the Suse forum.

While JohnVV expresses his opinion on using a disto with a longer release cycle, who knows what your reasons are, and you entitled to them.
For servers, I too would generally go with SLES, RHEL or Ubuntu Server LTS, but there is absolutely no reason you can’t run OpenSuse 12.3 if its shorter support cycle suits your needs.

As for getting No Machine running on 12.3, I’ve been able to get the 3.5 version running okay using the .rpms from the No Machine website. However, I’ve never been able to get the 4.x preview version to run.

Which version are you installing? Can you please post the output error?

Also, in case your interested in trying it, you might also consider freenx https://en.opensuse.org/FreeNX

I’ve had only one problem getting the new NoMachine 4 beta running on 12.3. That’s multimedia streaming. But otherwise, I installed the RPM, and it fired right up.

I have not had any problems either, works great. However, I have not tested audio streaming. Why not just use a really audio streaming program like Subsonic or Google play or any other one out there?

@ the OP have you actually installed 12.3, is it in a VM or on real hardware?

Its not for streaming audio as in just music. I’m talking about streaming the system sounds, which under Windows allows me to even watch a video over NX with almost no issue outside of some compression artifacts.

Unfortunately, while the framerate is pretty good for whatever I want to do, I just can’t seem to get audio redirection working under OpenSUSE.

Ok so you are really having problems with video sound or all sounds under openSUSE? Sorry for the dense questions.

Wait Hold Up, Did You Just Hyjak this thread…Yep
Yep again…
And I helped…

I’m having problems getting NoMachine NX server to redirect the audio from the system out to the client as it should. Locally, sound works perfectly fine. Its dead silent on the NX client.

Connecting to the same NX version on a Windows machine with the same settings, the NX client gets every ding, whoop, boing and whistle that I would hear if I were sitting right there.

YaST is not working with nomachine.

After click YaST, it pop up with a blank window.

I tried that.

Known “bug” with qt: (well, actually it is a permission problem caused by a security fix in qt, which results in empty windows for qt applications if run in VNC/NX)

I created qt packages without that security fix as a workaround (they don’t include many other current fixes as well as a consequence though, so I wouldn’t really recommend installing those anymore).
And another workaround would be to set the environment variable “QT_X11_NO_MITSHM” to 1 (maybe in your ~/.profile).

See also: