Hardware detection fails

I don’t think I have an exotic laptop since 42.3 installed fine on it.

Leap 15 hangs at hardware detection.

How do I get a verbose dump so I can watch to see what it fails on?


my installation also hangs at or right after the hardware detection (TP W520). It worked with a beta version of Leap 15 (end of december). And it still works with Tumbleweed. Behaviour ist not consistent, sometimes hardware detection seems to run endless. (Error)-Messages are the same in Tumbleweed and LEAP 15.


During installation? See if this helps…


Thank you that gets me into the non-GUI install. I’m to tired to see whether or not it blows up my system at 12 midnight.

I will say the documentation is confusing. Since I have a grub2 with UEFI install I read section 2.2.2 on this page:


The last sentence of that section says:

A complete list of parameters is available at SDB:Linuxrc - openSUSE Wiki

That page had hwdetect=0 which linuxefi gladly ignored.

But, when it said a “complete list” my literal translation was section 2.3 was legacy boot. Apparently that is not the case.

Thank you again. I will see if the non-GUI approach works when I have the energy. Since, the latest 42.3 kernel (I believe 132) lacks firmware for my bluetooth that worked in kernel 4.4.126-48 a re-install of 42.3 probably won’t be an option if 15 fails.

I know I could do an upgrade, but I’d rather chase issues on a clean install than an upgrade.

Had similar problems installing 15.0. The installation screen stopped with the progressing green line without any error messages.
With editing the boot lines, I added acpi=off and that allowed the installation.
15.0 did boot, but still only with acpi=off and therefore several problems in hardware detection,
like disabling my USB 2.0 ports (3.0 ports did work), screen too bright,…
I finally removed the acpi=off addition in the boot lines and installed a community kernel 4.16 together with a newer kernel-firmware package.
With this new kernel acpi=off isn’t needed any more for booting and the hardware seems to work as with 42.3.

In my case the regression to kernel 4.12 under OpenSUSE 15.0 seemed to create problems, I hadn’t had with all prior openSUSE versions.
Backported Spectre and Meltdown patches might cause these?

Thanks. That doesn’t give me much confidence of success. The Leap 42.3 132 kernel update also had the Spectre V4 patch. I am currently having to avoid that kernel.

This has nothing to do with linuxefi. Option was interpreted by linuxrc, but it had been removed 12 years ago. Care to open bug report (or file issue on github)?

As far as I can tell, today there is no way to skip hardware detection by linuxrc.

I’m happy to open a bug on the incorrect documentation. However, my google foo is failing and I cannot find any “correct” documentation. I would feel bad submitting a bug without a pointer to the correct documentation. For that matter I would be happy to fix the page myself if I could fine a correct list of parameters for linuxefi. or understood the issue better.

Once again - it has absolutely nothing to do with linuxefi.

You will need to dig into sources to actually find out what each keyword does.

Thank you for the link.

Try passing LXRCDebug=1 on kernel command line, it should give more verbose feedback during hardware detection.

my installation also hangs at or right after the hardware detection (TP W520). It worked with a beta version of Leap 15 (end of december).

Same here on my Thinkpad T520
Solved it like this:
disable the NVidia-GPU in BIOS and switch to Intel-GPU, then the installation runs. After, I did not switch yet to NVidia, so I don’t know if the problem continues.
This came to my mind while trying the KDE/Plasma-live-dvd and with NVidia-GPU the resolution stucked with 1240x1080, no choice possible.
I did not try any parameters in boot-sequenz


Just tested: switching back to NViidia after install on my T520, I get the same ugly screen as in kde-live.
With intel-GPU everything nice and smooth

Thank you for this tp.

Mine hangs on:

pci.2: get sysfs pci data

I flashed to the latest bios, but same issue.

I have not upgraded the Intel Management Engine. I don’t have a Windows system to boot into, and have not particularly wanted to create a Windows boot disk.

My Dell Latitude supports BIOS updates (which include Intel ME updates) directly from BIOS boot menu, just need to place exe file on any EFI accessible partition and select it. May be yours can do something similar?

Wish mine had that option, but I definitely thank you for that insight. I will look for that “feature” in my next purchase, because I don’t see that going away.

Another “feature” I need to look for when I upgrade hardware. I imagine this would extend battery life when mobile.

The suse kernel expert was nice enough to point me in the correct direction, and provide the information below:


This works to get Leap 15 installed:

There is also a link to a test kernel and updated release notes in the above link.

For you and anybody else using a ThinkPad W520, your problems are likely caused by the following BIOS bug, which Lenovo has not resolved: