Hardware acceleration on Firefox

Hi all.

I’m back with the same topic, this time with Firefox. I’ve installed intel-media-driver and enabled vaapi in Firefox. After restarting, I’ve tried to see if the hardware acceleration is enabled, but it’s still disabled.

I’ve also tried: sudo zypper remove MozillaFirefox and re-installed the browser via Flatpak. Flatpak hasn’t worked either, which is weird because it seems like browsers in flatpak never enable any codec. Chromium-based browsers are working with a flag instead.

Any suggestions?

Make sure that the codec the site is using is one supported by your card. If you’re watching av1 on YouTube and the best your card can do is VP9, you will not get hardware acceleration.

Hi!

iGPU is an intel 13th gen. As I mentioned, chromium based browsers are working.

What I forgot to mention is that the flatpak on fedora is working out of the box.

Nothing is really making sense at this point with the flatpaks, but I’ll give for granted that something is missing with Firefox on tumbleweed.

Here’s the solution. Sheesh.

Run the command and take note of the runtime version.

flatpak info org.mozilla.firefox

Firefox - Fast, Private & Safe Web Browser

     ID: org.mozilla.firefox
    Ref: app/org.mozilla.firefox/x86_64/stable
   Arch: x86_64
 Branch: stable
Version: 126.0.1
License: MPL-2.0
 Origin: flathub

Collection: org.flathub.Stable
Installation: system
Installed: 262,6 MB
Runtime: org.freedesktop.Platform/x86_64/23.08
Sdk: org.freedesktop.Sdk/x86_64/23.08

23.08!

Then install the ffmpeg.

flatpak install org.freedesktop.Platform.ffmpeg-full

Enable vaapi in about:config (in Firefox), restart the app.

The window buttons mismatch the theme and the video enhancement is not working, but for the rest this is the way.

It shouldn’t be this hard.

I was going to bite the bullet and start using chromium before I found out that ffmpeg-full makes a huge difference in performance.

org.freedesktop.Platform.ffmpeg-full will not auto update so Firefox will eventually start to run like ass again and you will have to install the new version of ffmpeg-full.

The issue is that Firefox chooses not to auto-install ffmpeg-full for legal reasons.

1 Like

That’s interesting, I had no idea.

So that one time that Flatpak’s Firefox worked with vaapi on Fedora was just something that happened once?

Also, what’s the alternative to the Flatpaks? Usually distros just want the intel media driver installed and the job is done, unless vaapi needs to be enabled on Firefox, but nothing else.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.