Hang up as 'Started Locale Service' ---- redux

Still hangs up at ‘started local service’ during the post up process right before the KDE splash screen.

So I’m thinking that the problem probably is something with KDE trying to start and won’t.

Hi Bill

I recall your earlier thread discussing this issue
https://forums.opensuse.org/showthread.php/532731-Desktop-hangs-at-locale-service
although I think this thread title is misleading, since it doesn’t appear (from the evidence presented in that thread) that systemd-localed is implicated in any way here. However, I do recall you having issues with getting a working KDE session. IIRC, you are now using XFCE successfully?

Sorry for the confusion. This is for the HP desktop that has KDE, and has since I installed it.
The Xfce machine is the laptop that has the nVidia and motherboard (optimus?) graphics that I had trouble installing KDE on. Never made it, hence Xfce on the laptop.

Anyway, this HP Compaq dc7700 CMT desktop hangs a lot of the time right before I usually see the KDE logo.
Which s why I am thinking something is interrupting the KDE session. Maybe KDE itself.

Anyway, after four hospital visits sine late June, I have one nerve left, and this hang up thing is on it like white on rice.

BTW, if a moderator is looking, the ‘preview post’ selection sends me to an error page (see admin).

Ok, thanks for clarifying Bill. I’m sure someone will be able to assist with this. When I have more time, I’ll check back in on this thread.

Anyway, after four hospital visits sine late June, I have one nerve left, and this hang up thing is on it like white on rice.

Keep your chin up Bill. Health is more important than mere technical issues.

BTW, if a moderator is looking, the ‘preview post’ selection sends me to an error page (see admin).

I passed the message along to my fellow mods, but I can’t replicate it here. BTW, which browser are you using?

Hey Bill, when you get a chance please let us know the graphics specs of this machine using the following…

/usr/sbin/hwinfo --gfxcard
inxi -Gxx

At the time I was using a chromium version - Slimjet, my preferred Chrome look alike on the HP desktop.

OK, will do.

Here it is:

**localhost:~ #** /usr/sbin/hwinfo --gfxcard
26: PCI 100.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.378]
  Unique ID: VCu0.2TBPljRrRTA
  Parent ID: vSkL.Uuuz1sBavA3
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI Cedar [Radeon HD 5000/6000/7350/8350 Series]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x68f9 "Cedar [Radeon HD 5000/6000/7350/8350 Series]"
  SubVendor: pci 0x1682 "XFX Pine Group Inc."
  SubDevice: pci 0x3030  
  Driver: "radeon"
  Driver Modules: "radeon"
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  Memory Range: 0xf0400000-0xf041ffff (rw,non-prefetchable)
  I/O Ports: 0x2000-0x2fff (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 26 (46242 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d000068F9sv00001682sd00003030bc03sc00i00"
  Driver Info #0:
    Driver Status: radeon is active
    Driver Activation Cmd: "modprobe radeon"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #23 (PCI bridge)

Primary display adapter: #26
**localhost:~ #** inxi -Gxx
If 'inxi' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf inxi

Ok, so AMD/ATI graphics with the open source radeon driver in use.

**localhost:~ #** inxi -Gxx
If 'inxi' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf inxi

You need to install the ‘inxi’ package first.

zypper in inxi

Bill, is this desktop set to “auto-login”, or do you get presented with a working login screen?

You should be able to get to a VT (eg CTRL+ALT+F2), login as root and do

systemctl status display-manager

Any errors? Take a picture if easier to come back with the info.

It goes through the post up scripting, and if it does not hang up, it goes to a KDE splash screen(for a long long time), and then to my desktop.
So I think you would say it is ‘auto-login’. Do you think I should not do the auto-login?

**localhost:~ #** systemctl status display-manager
**●** display-manager.service - X Display Manager
   Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
   Active: **active (running)** since Sat 2018-09-29 16:17:18 CDT; 2h 20min ago
 Main PID: 1493 (sddm)
    Tasks: 6 (limit: 4915)
   CGroup: /system.slice/display-manager.service
           ├─1493 /usr/bin/sddm
           └─1507 /usr/bin/X -nolisten tcp -auth /run/sddm/{12fd082a-9b4f-4993-a865-6e91b28bdecb} -background none -noreset -displayfd 18 -seat seat0 vt7

Sep 29 16:17:35 localhost.localdomain sddm[1493]: Adding cookie to "/run/sddm/{12fd082a-9b4f-4993-a865-6e91b28bdecb}"
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Starting...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Authenticating...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] returning.
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: pam_unix(sddm-autologin:account): password for user <XXXX> will expire in 99916 days
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Preparing to converse...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Conversation with 1 messages
Sep 29 16:17:36 localhost.localdomain sddm[1493]: **Authentication information: "Warning: your password will expire in 99916 days"**
Sep 29 16:17:36 localhost.localdomain sddm[1493]: Authenticated successfully
Sep 29 16:17:38 localhost.localdomain sddm[1493]: Session started

Ok, so it does start the KDE desktop successfully sometimes.

So I think you would say it is ‘auto-login’. Do you think I should not do the auto-login?

Not necessarily. It might be useful to know if creating another user makes a difference starting the desktop (logging in with the new user account) though.

This looks as expected…

**localhost:~ #** systemctl status display-manager
**●** display-manager.service - X Display Manager
   Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
   Active: **active (running)** since Sat 2018-09-29 16:17:18 CDT; 2h 20min ago
 Main PID: 1493 (sddm)
    Tasks: 6 (limit: 4915)
   CGroup: /system.slice/display-manager.service
           ├─1493 /usr/bin/sddm
           └─1507 /usr/bin/X -nolisten tcp -auth /run/sddm/{12fd082a-9b4f-4993-a865-6e91b28bdecb} -background none -noreset -displayfd 18 -seat seat0 vt7

Sep 29 16:17:35 localhost.localdomain sddm[1493]: Adding cookie to "/run/sddm/{12fd082a-9b4f-4993-a865-6e91b28bdecb}"
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Starting...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Authenticating...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] returning.
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: pam_unix(sddm-autologin:account): password for user <XXXX> will expire in 99916 days
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Preparing to converse...
Sep 29 16:17:36 localhost.localdomain sddm-helper[1798]: [PAM] Conversation with 1 messages
Sep 29 16:17:36 localhost.localdomain sddm[1493]: **Authentication information: "Warning: your password will expire in 99916 days"**
Sep 29 16:17:36 localhost.localdomain sddm[1493]: Authenticated successfully
Sep 29 16:17:38 localhost.localdomain sddm[1493]: Session started

I’ve never been impacted by sddm-greeter issues like this. FWIW, I note an “old but interesting” bug report discussing similar behaviour
https://bugs.gentoo.org/553996
I’ll let you digest that for yourself.

As a workaround, try using the lightdm display manager instead…

sudo update-alternatives --config default-displaymanager

change to lightdm then reboot. Let’s see if that results in “consistently started” desktop. Although not a resolution (with respect to whatever is happening with SDDM), it might be a pragmatic option to moving on with this issue.

Yes sometimes, I never know if it will or not.

OK, this I can do, will post back.

You do mean starting a user account via the login prompt, yes?

Yes, but also check out my other suggestion to try switching to lightdm display manager. That might be all that’s needed here.

FWIW: I do not bother with SDDM, for several reasons, one being this type of issue is quite common, another is that SDDM does not work well with VNC.

I much prefer LightDM.

OK, I have a second user defined, no auto-logins, and changed to lightDM.
When i boot now it goes through it’s scripting thing, then the login screen, after the login>THEN it goes to the KDE splash(which is still a long long time).
We’ll see over the next few days if it hangs up.
Thanks to both of ya’s
Bill

PS> anyway to remove the other DM’s from the login screen picks at top right?

HA! original user(me) gets a KDE splash screen. the second user gets the gecko light bulb(strange?)
But the ‘DM picker’ up top shows Plasma as being checked. I don’t understand the difference.
also, (I need to look into iceWM, Plasma, Plasma(Wayland) and the other one I forgot).

Don’t get yourself confused Bill. The lightdm login screen offers different desktop sessions (as does sddm etc). All that was suggested was to change the display manager (which manages desktop sessions and authentication). Keep using Plasma (KDE), unless you want to change the desktop environment for some reason.

I only get the light bulb splash for all users. Hadn’t realised this is not the case for you.

But the ‘DM picker’ up top shows Plasma as being checked. I don’t understand the difference.
also, (I need to look into iceWM, Plasma, Plasma(Wayland) and the other one I forgot).

As I mentioned in my last post, you’re looking at the desktop session chooser. I’m hoping that you can keep using KDE as your chosen desktop environment (DE), while using lightdm as the underlying desktop manager.

These wiki articles may help with your understanding here…
https://en.wikipedia.org/wiki/X_display_manager_(program_type)
https://en.wikipedia.org/wiki/Desktop_environment