Handbrake crashes "Illegal Instruction (core dumped)"

I’m running openSUSE Tumbleweed KDE x86_64 and I installed Handbrake from the Packman repository. When I try to run it, it simply exits immediately, so I tried running it in a terminal. This is the error message I got when trying to run both the GTK and CLI versions of Handbrake in a terminal:

Illegal Instruction (core dumped)

And that’s it. No other error information was presented. Everything else works fine on my machine, and before I installed Linux I briefly installed Windows 7 to test the hardware. The machine survived 24 hours of memtest86 (booted from a CD) and 36 hours of Prime95 “blend” torture test (run under Windows 7). After testing the hardware, I wiped the entire SSD, including the MBR, and installed openSUSE Tumbleweed by itself. Since I installed Tumbleweed, I have spent many hours playing Star Wars: The Old Republic through Wine with no issues, and I have spent many more hours using Firefox and VLC player, which work fine as well.

I did install the proprietary Nvidia drivers using the available repository, if that makes any difference. The only unofficial repositories I’m using are Packman, libdvdcss, and Nvidia, all Tumbleweed versions. I have installed everything presented by “zypper inr” and I run “zypper dup” at least once per week. It’s possible that I’m missing some dependencies but I’ve been very careful to make sure to install all dependencies and avoid conflicts, per the Tumbleweed multimedia guide on these forums.

I have received several Handbrake updates over the last few weeks, and each time I thought they would fix my issue, but they did not. I have been Googling this problem for over an hour and I could not find any other example of it.

I’m comfortable with the command line but I’m relatively new to Linux and I have not yet learned how to use debugging tools. I build PCs for fun but I’m more of a mechanic than an engineer. Any help would be appreciated.

My machine:
AMD Phenom II x6 1100T
MSI NF980-G65 motherboard
4x4GB Kingston HyperX Fury DDR3-1600
MSI GTX 660Ti Twin Frozr (3GB VRAM)


I was able to run handbrake on Leap 15.0 (or maybe 15.1, not sure) without any issue. Can you see anything related in the syslog (/var/log/messages or journalctl) that was issued when the coredump occurs? Does


reveal anything?

These are the last three lines of dmesg output immediately after running the GTK version of Handbrake:

  668.843805] BTRFS info (device dm-2): qgroup scan completed (inconsistency flag cleared)
[15384.987365] show_signal: 15 callbacks suppressed
[15384.987372] traps: ghb[7279] trap invalid opcode ip:7fea05ef76d1 sp:7ffebbe7ff50 error:0 in libmfx.so.1.30[7fea05ef5000+5000]

Thank you for telling me about dmesg, I did not know that command before today. I will be sure to use it in the future.

Upon further inspection of the dmesg output, the problem appears to be with libmfx. Both libmfx and libmfx1 are installed, and I just installed libmfx-devel for good measure, but Handbrake still crashes with the same error.

Edited to add: There is only one version of libmfx, libmfx1, and libmfx-devel available to me, all from the official OSS repository. It seems that Packman doesn’t provide that package.

Thank you for telling me about dmesg, I did not know that command before today. I will be sure to use it in the future.

At least one thing I could provide :wink:
I’ve never used TW so I can’t really reproduce it at the moment. Do you have older versions available for libmfx that you could try?

Issues could be caused by setup of your system. No problems with handbrake-gtk 1.3.1-4.4 encountered here.

Are you referring to my hardware setup, or something software-related that might be specific to my installation?

As for libmfx, it looks like the only version available is the one I have installed. It seems Tumbleweed only provides one version of most packages at any given time (I imagine that is intentional).

I presume handbrake runs on any hardware. So there is a dependency problem:

erlangen:/home # zypper if --requires  handbrake-gtk
Loading repository data...
Reading installed packages...

Information for package handbrake-gtk:
Repository     : Packman                       
Name           : handbrake-gtk                 
Version        : 1.3.1-4.4                     
Arch           : x86_64                        
Vendor         : http://packman.links2linux.de 
Installed Size : 10.6 MiB                      
Installed      : Yes                           
Status         : up-to-date                    
Source package : handbrake-1.3.1-4.4.src       
Summary        : Multithreaded Video Transcoder
Description    :                               
    HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded video

    This package contains a GTK+ graphical user interface for Handbrake.
Requires       : [61]                          

erlangen:/home #

You need to pick the correct version of each of the 61 libraries involved. Make sure you load them from repos repo-oss and repo-non-oss. If there is a matching version in repo Packman use this instead:

erlangen:/home # zypper lr -uEP
#  | Alias               | Name                                           | Enabled | GPG Check | Refresh | Priority | URI                                                                            
 3 | Packman             | Packman                                        | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/                            
 8 | openSUSE-20191106-0 | openSUSE-20191106-0                            | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/                              
11 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss                    | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/                          
13 | repo-update         | openSUSE-Tumbleweed-Update                     | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/                                
erlangen:/home # 

If in doubt temporarily disable all but the above repos. Run:

erlangen:/home # zypper dup --allow-vendor-change --from Packman
Loading repository data...
Reading installed packages...
Computing distribution upgrade...

Nothing to do.
erlangen:/home # 

Thanks very much for this information!

I followed these steps and they did not install any new packages, so I opened YaST and switched all packages to versions in the official OSS repository, which downgraded a bunch of packages. I tried running Handbrake-GTK again in a terminal, but the same error occurred. Then I used YaST again to switch back to Packman, which upgraded the packages I just downgraded. I got the same error when running Handbrake again.

I did a little research on libmfx, and it looks like it’s intended to provide access to Intel Quick Sync Video on Intel integrated GPUs. I have no Intel hardware in my machine, which makes me wonder why that library is causing problems when it should just be sitting there uselessly.

I tried to run:

zypper rm libmfx libmfx1 libmfx-devel

And I’m glad I selected “no” when asked to proceed because that command would have uninstalled most of KDE. I’m not sure why a library specific to Intel hardware is so integral to a machine that lacks any Intel hardware.

To make sure you don’t have stale configuration items you may check for consistency by cleaning caches:

  • zypper clean --all
  • zypper refresh --force

Check for stale packages:

erlangen:~ # zypper packages --installed-only  |grep @System
i  | @System                                        | boost-license1_66_0                      | 1.66.0-lp151.4.5                      | noarch
i+ | @System                                        | kernel-default                           | 5.5.4-1.2                             | x86_64
i+ | @System                                        | kernel-default                           | 5.5.2-1.1                             | x86_64
i+ | @System                                        | libboost_filesystem1_66_0                | 1.66.0-lp151.4.5                      | x86_64
i  | @System                                        | libboost_program_options1_66_0           | 1.66.0-lp151.4.5                      | x86_64
i  | @System                                        | libboost_system1_66_0                    | 1.66.0-lp151.4.5                      | x86_64
erlangen:~ # 

Video driver issues can occur for many reasons: https://forums.opensuse.org/showthread.php/519529-Konsole-With-quot-su-quot-Freezing-The-System

Posting your hardware will help:

erlangen:~ # inxi -zFxx
System:    Host: erlangen Kernel: 5.5.5-1-default x86_64 bits: 64 compiler: gcc v: 9.2.1 Console: tty 0 wm: kwin_x11 dm: SDDM 
           Distro: openSUSE Tumbleweed 20200224 
Machine:   Type: Desktop Mobo: ASRock model: Z170 Pro4S serial: <filter> UEFI: American Megatrends v: P3.50 date: 06/23/2016 
CPU:       Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S rev: 3 L1 cache: 256 KiB 
           L2 cache: 8192 KiB L3 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63999 
           Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 802 6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1912 
           Display: server: X.Org 1.20.7 driver: modesetting unloaded: fbdev,vesa alternate: intel compositor: kwin_x11 
           resolution: 1920x1200~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASRock driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k5.5.5-1-default 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           chip ID: 8086:15b8 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k v: kernel port: f040 bus ID: 03:00.0 
           chip ID: 168c:002e 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 8.20 TiB used: 1.79 TiB (21.9%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 950 PRO 512GB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> temp: 34 C 
           ID-2: /dev/sda vendor: Western Digital model: WD40EZRX-22SPEB0 size: 3.64 TiB speed: 6.0 Gb/s serial: <filter> 
           ID-3: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB speed: 6.0 Gb/s serial: <filter> 
           ID-4: /dev/sdc type: USB model: 1Intenso External USB size: 3.64 TiB serial: <filter> 
Partition: ID-1: / size: 59.45 GiB used: 12.56 GiB (21.1%) fs: btrfs dev: /dev/sdb5 
           ID-2: /home size: 406.34 GiB used: 242.74 GiB (59.7%) fs: ext4 dev: /dev/nvme0n1p3 
           ID-3: /opt size: 59.45 GiB used: 12.56 GiB (21.1%) fs: btrfs dev: /dev/sdb5 
           ID-4: /tmp size: 59.45 GiB used: 12.56 GiB (21.1%) fs: btrfs dev: /dev/sdb5 
           ID-5: /var size: 59.45 GiB used: 12.56 GiB (21.1%) fs: btrfs dev: /dev/sdb5 
           ID-6: swap-1 size: 26.82 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 29.0 C mobo: 29.0 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 1184 fan-3: 0 fan-4: 0 fan-5: 0 fan-6: 0 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.34 vbat: 3.10 
Info:      Processes: 278 Uptime: N/A Memory: 31.05 GiB used: 2.19 GiB (7.1%) Init: systemd v: 244 runlevel: 5 
           target: graphical.target Compilers: gcc: 9.2.1 alt: 9 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.32 
erlangen:~ # 

Same problem here:

  350.214457] traps: gst-plugin-scan[6188] trap invalid opcode ip:7f8d55de76d1 sp:7ffcbfceba90 error:0 in libmfx.so.1.31[7f8
  350.253482] traps: gst-plugin-scan[6201] trap invalid opcode ip:7f4fe51486d1 sp:7ffe0e3ff7e0 error:0 in libmfx.so.1.31[7f4
  353.167790] traps: ghb[6187] trap invalid opcode ip:7ffb239f66d1 sp:7ffd10237570 error:0 in libmfx.so.1.31[7ffb239f4000+50

Have a read of this Packman ML thread: http://lists.links2linux.de/pipermail/packman/2020-March/016262.html

It may prove useful to notify the maintainers at the email addresses in the changelog about this thread:

rpm -q --changelog handbrake-cli | head

. Otherwise, or additionally, report a bug.

I notified the maintainer this morning, July 15, 2020. I run 15.2 and have an identical problem. I have started a new post concerning this in Leap 15.2

Snapshot 20200714 breakes multimedia. Options offered by yast2 don’t work. Thus I rolled back to 20200710, where ghb and everything else works fine.