GUI doesn't start

First of all, sorry for my English…


I have installed Opensuse 11.1 from DVD (I made it a few months ago). It worked well. But I have updated something (the ATI driver?) and now my Linux doesn’t boot anymore.

When I boot I get the green screen with the logo of opensuse and a ‘loading beam’.the full beam gets loaded but after that i have a black screen with some flashes. So I think the kernel doesn’t load the GUI anymore. The only thing that I can do is pressin Ctrl-Alt-Del and the laptop reboots.

Linux is pretty new for me so I don’t know if i use the correct terms but i hope you can give me a good answer!

Hi there,

Let’s get some more info and that will help set you on the right track.

First, you can press Escape on the green screen and see the boot messages.

Then, once booted, go to a virtual terminal - press: ctrl+atl+f2 through f6 and you will get a log in prompt. Log in and look at some logs, such as:

see what that says

$tac /var/log/messages | less
That will show that log in reverse order (most recent message first)

Then I would suggest trying to make a new Xorg config with:
(You need to be root to run that one.)

Now, all that is just some general suggestions - but if you can provide some more of what you see in doing so, I am sure you issue can be easily resolved.


i am having a similar issue. I am booting opensuse 11.1 on a amd 64 3400+ with a ati 9800 pro wit a 52inch samsun LCD tv as my monitor. after installing suse i get all the way till it boots then the tv goes blank and i am getting a message from the TV “mode not supported”…had the same problem with windows 7 and changed from an analod vga to pc port to a dvi to hdmi port and it solved the problem with windows. it didn’t do anything with suse. i then tried to boot in fail safe with no avail. anyone help?


Thanks for helping but I’ve reinstalled openSuse yesterday and i works fine now. :slight_smile:

Try hitting the number 3 of your keyboard and then boot opensuse. At the text login login as user and password then at the next prompt type** su** then the root password, the next prompt again type sax2 -r -m 0=vesa (0 is zero not letter O) wait for the sax2 configuration it might take you to the sax2 gui window, if prompted to save or configure choose configure do the appropriate selection for your monitor. e.g; lcd, size etc, click ok, save, exit. At the next text prompt type** init 5** and see if it will take you to the gui login screen.

Second option: If you cannot see the size of your lcd display.
In sax2/yast2 monitor choose lcd and click change, In display size-diagonal and aspect ratio, under diagonal choose not configured and in Display size(mm) fill in the x axis(horizontal) and y axis(vertical) measurement of your screen in millimeter. Click okey, and save as prompted.Logout and login.

Note: As soon as you fill-in the right x and y axis measurement you will notice that under diagonal size, the not configured will change into the size of your monitor.

Again the same problem!
But I want to solve the problem now, that’s a good way of learning to work with linux…

I installed VirtualBox for multibooting with windows vista, but also updated some programs like firefox and i think something with the ati driver also.

Now I’ve uninstalled virtualBox because that was a line that failed while booting (pressing escape while the green screen with the ‘loading beam’ was loading).

When I press Escape while booting now, everything likes normal. All the lines are ‘done’. Just at the end I have:

“Skipped services in runlevel 5: smbfs nfs xend xendomains”

And then the possibility to login.

So I login as root…
Yast2 works, because i could uninstall virtualbox.

But the troubles are with Sax2, my computer blocked.
Thing i tried:

Sax2 -r -m 0=vesa
sax2 -r -m 0=fglrx
init 5

nothing works… just a black screen and afther that nothing happens

Other specifications:
Ati mobility radeon hd 3470
opensuse 11.1 with KDE 4.1