Guake is removed

Hello Dears,

It’s been more than 5 years than I’m using Guake as my default terminal emulator on daily basis.
after my last Tumbleweed upgrade “20180404” I noticed that it’s removed and now I feel paralyzed without that!

I’ve tried to install it from CLI :

zypper in guake

Loading repository data…
Reading installed packages…
‘guake’ not found in package names. Trying capabilities.
No provider of ‘guake’ found.
Resolving package dependencies…

Nothing to do.

and tried installing with 1 Click Install:
Software installation
Installation was only partially successful.
The following packages could not be installed

  • guake

Unfortunately I can’t find any logs mentioning why this happens.

I would appreciate if anybody help me to find out what is the root cause of my errors and what breaks the package.

With Regards,

you could install yakuake, it will pull in some KDE deps, but works fine in GNOME and other DE’s. The reason for guake being dropped is probably lack of upstream maintenance, package maintenance and so on.

Guake is still available for Tumbleweed from the X11:terminals repo/project though:

Last update (from 0.8.13 to 3.0.5) was just 5 days ago.
So the upstream maintenance seems not to have been the “problem” here… :wink:

Hey wolfi323,

Of course it’s available but I’m not able to install guake with direct/1 click install and it just says installation was partially successful with no logs showing what’s wrong.
Unfortunately this is my first time facing such a problem after one year of Tumbleweed and 5 years of opensuse usage. :question:

And what 1-click install are you using exactly?

Try the link I gave you (use the one for “openSUSE Factory”, that’s suitable for Tumbleweed), if the 1-click install shouldn’t work for some reason follow the instructions there for manual installation.

I was using this link but was not working.
I didn’t noticed that your link is different lol! and it solved my problem BTW.

Thank you :slight_smile:

Yes, but that page lists all available guake packages (for all distributions) on OBS.
On which of the results did you click exactly?
I suppose the 0.4.2 for Tumbleweed, which seems to be a stale cache/index entry as that version doesn’t exist anymore since years… (even openSUSE 12.2, released 2012!, had 0.4.3 already :wink: )

No longer relevant though as you got it installed now anyway.

The latest 3.0.5 from X11:terminals is available on that page too (and should work) though, but only under “Show experimental packages”.
My link was a direct one to the download page of this specific package/repo.

Btw, it got dropped from Factory/Tumbleweed because it (0.8.13) was “No longer installable, since python-gconf is dropped”.
The package maintainer wrote:

It’s true. There is a new gtk3 version, but it is not designed to be built and installed system-wide, I think (very weird build tools too, I tried to build it on obs with no luck.)

But someone else stepped in and apparently managed to get 3.0.5 built/installed system-wide.

So maybe it will be added back to the standard repos in the future, but that’s up to the package maintainers…

Interesting. I never knew that there was a “guake”.

I do regularly use “yakuake” with Plasma. I’m glad to hear that will also work in Gnome, if I start it there.

There is also Tilda… unfortunately this doesn’t work under wayland properly (1080341 – tilda is crashing in wayland session) when the switch comes, apps like this may break until they are ported. At present with wayland and Gnome I use the dropdown terminal extension.

At least yakuake should support Wayland just fine.
The latest versions always contained improvements for Wayland as well.

Regarding Guake, they say this in the README:

Note on WaylandThere are some reports of Guake not opening when a Wayland app or empty desktop is focused. The issue has been reported on Ubuntu 17.10 LTS, Fedora 26 and Fedora 27. For more context, see issue #1041.

The workaround is setting a manual keybinding as described above. On Fedora 26, for example, this can be accomplished by going to Settings > Keyboard and adding a new custom shortcut to execute guake -t.