Grub2 installation failed 15.4

New installation on a laptop, help needed. previously had 15.1 on it. New install is 15.4. At 98% of the installation the Grub2 failed.

Installation error message:
Execution of comment “[[”/usr/sbin.shim-install’,‘–config.file=/boot.grub2/grub.cfg’]]’ failed.
Exit code:1
Error output: cp: error writing ‘/boot/efi/EFI/opensuse/MokManager.efi’: No space left on device

note: but the partition for EFI is 3.5g

boot error:
error: …/…/grub-core/fs/btrfs.c:309: not a Btrfs filesystem
error: …/…/grub-core/kern/fs.c:121:unknown filesystem.
Entering rescue mode. . .
grub rescue>

I then tried an update from the installation media to let grub2 reinstall. Still failed near the end with the same errors

What would be the next step?
thank you.

You will need to look at what is taking so much space on the EFI partition. And clean some of it out.

At a pinch, you could try disabling the secure-boot support (and also disable secure-boot in the BIOS). The amount of space needed without secure-boot support is smaller.

Show actual facts from your system. Start with df -h output.

thank you for your reply. I was mistaken on the size of the partition, it is 3.5 mg.

I was able to reinstall and changed from Ext4 to Btrfs and now have a successful installation. However it no longer finds the Windows OS.

Same event new question. How do I get Windows back? I have verified in the YaST boot loader that “Probe Foreign OS” is checked. Windows is not found.

any help is appreciated

All OS must use same boot methods to be see from each other.

Also In Windows Fast boot must be off.

2 most common reasons for Windows not seen problem.

In this case where the system is not showing windows, how do I apply what you are saying? What do I need to do to get windows back? I don’t see anything in the bios for fast boot. It was set to legacy to see opensuse

You need to give us some actual information, as requested by @arvidjaar in message #3 of this thread.

Sometimes even though the box is checked, Windows doesn’t get included until after something happens to cause grub2-mkconfig to be run subsequent to initial installation. You can do that with YaST by changing the timeout value from whatever it is now to anything else, then apply and reboot.

Note that you can , assuming it is intact , start Windows via BIOS/UEFI boot options. Note again that all OS’s on a machine must use the same boot methods (Legacy/MBR or EFI) and that Windows fast boot must be off if they are to work with each other.

This needs clarification. I have a Gigabyte UEFI PC with NVME, plus 2 HDDs comprising several RAID1 devices. The HDD pair was transferred from an older PC with neither NVME nor UEFI support. All dozen or so Linux installations on the GPT NVME are bootable from Grub2-efi on ESP without any special keystrokes or menus. All 4 Linux installations on HDDs are bootable from Grub Legacy without involving the NVME in any way, by using the BBS hotkey during POST. The TW installation on RAID can be booted either via ESP or Grub Legacy.

thank you. sorry I missed this and for the delayed response.

df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 4.0M 0 4.0M 0% /dev
tmpfs 2.9G 0 2.9G 0% /dev/shm
tmpfs 1.2G 18M 1.2G 2% /run
tmpfs 4.0M 0 4.0M 0% /sys/fs/cgroup
/dev/mapper/system-root 35G 4.8G 31G 14% /
/dev/mapper/system-root 35G 4.8G 31G 14% /boot/grub2/i386-pc
/dev/mapper/system-root 35G 4.8G 31G 14% /boot/grub2/x86_64-efi
/dev/mapper/system-root 35G 4.8G 31G 14% /root
/dev/mapper/system-root 35G 4.8G 31G 14% /opt
/dev/mapper/system-root 35G 4.8G 31G 14% /srv
/dev/mapper/system-root 35G 4.8G 31G 14% /usr/local
/dev/mapper/system-root 35G 4.8G 31G 14% /tmp
/dev/mapper/system-root 35G 4.8G 31G 14% /var
/dev/sda6 86G 5.7G 80G 7% /shared
/dev/sda1 260M 5.1M 255M 2% /boot/efi
/dev/mapper/system-home 40G 278M 37G 1% /home
tmpfs 587M 84K 587M 1% /run/user/1000

I mounted the windows partitions to identify the UUID of each. They are:

UUID=8A465F18465F03FB /windows10
UUID=543259BF3259A730 /windowsRE

This was needed when your problem was lack of space. Now your problem is entirely different and unrelated to how much space is available (and as usual this topic has drifted away from what is indicated in the subject).

Show output of fdisk -l.

P.S. On these forums we very much prefer to have one topic - one problem. Your original problem was solved and if you have another question then start another topic with clear subject.

thank you. I will open an new topic with this information and a specific topic.