grub2-efi for win10 / linux dual boot, but yast doesn't see efi

I have a new laptop with win10, running via efi boot. I read on the forum to install Linux, and then using YaST reinstall the bootloader as the grub2-efi to get back to a normal dual boot system. Everything was installed with no issues. I am using a Super Grub2 disc to boot into Linux. Without that the computer will only boot into win10. In linux YaST bootloader, selecting the Yast2-efi mode, it says that it cannot locate an efi boot on this computer. It is on its own partition. I will provide the partition maps when I can next, I am posting this from my desktop system.

My question is how to set up grub2-efi so we can get back to a clean dual boot. Thank you in advance for the help.

It is not quite clear how things went.

When you have an EFI system, you should boot the install media (DVD, USB stick) also in EFI mode. The installer will then detect that the system is EFI and configure GRUB for that, including multi-boot.

Didn’t that work for you?

First, from Windows, create some free space. Then boot from a USB Install medium, in the Expert Partitioner you should see the free space and the partitioning openSUSE’s installer suggests. If it suggest a separate partition for /boot/efi, accept that. In the Summary, check the bootloader settings and make sure that probing for foreign OS’s is checked, That should present you with a dual boot.

Thank you for the reply. It looks like this process will then require a new installation.

Is there a method to change the bootloader without requiring a new install?

How is that done? I did not see that option.
The media booted and installed. Is the post below yours what you are referring to?

Is there a means to manually reload grub-efi?

I will post the partition table when I can later tonight.

As I did not quite understand what you describe (I know it is not easy to describe the important details of what you saw and did after a few hours or more), thus I decided to describe what should have happened and I hoped that you then would come back with something like: “at that point there happened something else”.

You describe that the installation was without issues, but you seem not to have a dual boot. So IMHO that is an issue.

So again, after the installation, you should have a normal dual boot (EFI) system. I do not understand if you had that or not. I also do not understand why you did “and then using YaST reinstall the bootloader as the grub2-efi to get back to a normal dual boot system”.What was wrong and why did you think so?

I for myself will not give any advice before I understand what your situation is and how you reached there.

Thank you and that is fair. I will get more info out when I have the chance at home in front of the computer.

Maybe at this stage, we should ask how you prepared the installer. Is this from the downloaded DVD installer or downloaded live iso? Did you then burn to a DVD? Or did you copy to a USB. And if you used a USB, how did you copy?

Maybe also tell us what computer you are using (manufacturer, model).

Actually the openSUSE installer detects whether your UEFI is set to boot in UEFI- or in CSM-mode. So if your MS Windows installation boots in UEFI-boot-mode (and you did not change anything in your UEFI before you started the openSUSE-installation) then the openSUSE-installer should have booted in UEFI-mode and should have installed GRUB2 for UEFI-boot-mode (assuming you did not change the default bootloader setup during the installation).

The main indication that the openSUSE-installer was booted in UEFI-mode is that there are no F-key settings offered on the bottom of the very first installer screen. So given you did not change your UEFI boot mode before the installation and used just the default bootloader setup of the installer you should have ended up with a working GRUB2 dual boot.

There is a chance that the openSUSE installer failed to setup your UEFIs NVRAM correctly. Could you please start your system with Super Grub2 disc or start the rescue system from the openSUSE installation media and show (as root) the result of

# efibootmgr -v



I’m guessing that he will get an error message, something like “efivar not found”. And that’s because I don’t think he is booting in UEFI mode.

If he does get a good answer from “efibootmgr”, then he can easily fix the problem.

Please first show us

cat /etc/fstab

If you use the Windows EFI partition to boot Windows from, you may have to check it. I’ve recently seen a laptop where the file system on it was not shutdown properly ( leaving a dirty-bit ). Fixing that first also fixed the dual boot issue.

If OPs MS Windows is booting in UEFI-mode and OP did not change his UEFI-setup before he started the openSUSE-Installation then why should the openSUSE-Installer be booted in CSM-mode?

However only OP knows …



Yes, exactly. And we are waiting to hear.

Sorry for the delay. It has been a very busy week both at home and at work.

correct on the error for efibootmgr -v.
error: can’t find command ‘efibootmgr’

I’m pretty sure that the command is there.


/usr/sbin/efibootmgr -v

To start from clean again, I was trying to reinstall using openSUSE-Tumbleweed-DVD-x86_64-Snapshot20190412-Media. I used openSusE Image Writer to create a usb stick to install. I am in the YaST2 installation, expert partitioner. I have been using this since 7.0 and have to say this is the most confusing and least documented version I have seen. The help button in the lower left of the installation window used to provide information on each step or section on that page. The help has been dumbed down significantly. I can’t see via the installer how or which

As for the YaST installation tool, it has me baffled.
There will be 3 partitions with OS’s that need to be bootable. How should they be tagged, and with what flag?

  • windows 10 home
  • Gecko Linux Rolling w/ Cinnamon
  • OpenSuSE Tumbleweed (trying to install this now)

I created a 9 GB /boot has a partition
I tried it as EFI System, but get the following error:
It set up a mount point of /boot/efi

When I select accept YaST2 warning:

The system might not be able to boot:
 - A partition of type BIOS Boot is needed to install the bootloader.
 - Such a setup is not supported and may cause problems with the bootloader now or in the future.

I changed it to partition id of BIOS Boot
It set up a mount point of /boot/efi

When I select accept the same YaST2 warning comes up.

It never used to be this crazy

The laptop is a Lenovo ideapad 110

As best I can by typing, this is the partitions:

  sda1  Diagnostics  NTFS  Recovery
  sda2   EFI System  FAT 
  sda3   Microsoft Reserved
  sda4   Windows Data   NTFS   windows-C   **(OS, should be bootable) **    /windows-C
  sda5   Windows Data   NTFS   shared_data     /shared_data
  sda6   BIOS Boot   FAT    /boot/efi
  sda7   Linux Native  Swap
  sda8   EFI System   Ext4  cinnamon_linux  **(OS, should be bootable) **    /cinnamon
  sda9   Linux Native   Ext4   linux_home     /home
  sda10  Diagnostics  NTFS WINRE_DRV
  sda11  Diagnostics NTFS LENOVO_PART     /lenovo
  sda12 Linux Native  FAT   LRS_ESP
  sda13  EFI System   Ext4  Tumbleweed_linux **(OS, should be bootable)** new one / I am trying to install   **  / **

So many partitions it’s crazy. I really appreciate the help

The install media can be booted in UEFI mode. And it can be booted in legacy mode.

I’m pretty sure that you only get that warning if you booted in legacy mode.

Since Windows uses EFI booting, you need to boot the install media with EFI.

Try this blog post booting the installer
It explains how to tell whether you are booting with EFI mode or legacy mode.

You might have to go into BIOS settings on your Lenovo, and configure it to boot with UEFI. (On my Lenovo, there’s a setting for prefer UEFI booting).

I changed the bios to be UEFI only as opposed to UEFI & Legacy. It will not boot from the usb.

it continues to try to boot, but there is a warning window:

Secure Boot
Image failed to verify with ACCESS DENIED
Press and key to continue.

It then proceeds to load windows 10.

So it won’t accept the usb drive to install.

I am reading the link you

I disabled the secure boot in the bios and the usb opened to the installer. some success. I am trying the installation again. Based on the article you mentioned above, this is now in UEFI mode.

Okay. Just leave “secure-boot” disabled for the present.

My Lenovo (a desktop system) had the same problem with secure-boot. A later BIOS update fixed that.

Take a look at this page:


and scroll down to the section with title “Booting the Machine that supports only one signature with vendor provided Keys”

That explains how to get secure-boot to work. However, I found that a lot of trouble, because some opensuse updates will reinstall booting, and then you have to do that all over again. So it is easier to leave secure-boot disabled.