grub2 command line

So, I tried booting this morning, and I just get the GRUB command line (grub> ). I guess I should boot gparted and check partitions? Did some recent 13.1x64 update break GRUB? I see the two lines for grub flash by before the command line appears. BIOS shows the HD is present and accounted-for…

OK - got boot back by running gparted and checking / and /home partitions. But now it’s not seeing my mouse. Maybe it’s the NVIDIA driver needing to be reinstalled…

If a kernel update you may need to reinstall if you installed the hard way. If from the repo it should rebuild the driver for the new kernel via the KMP stuff.

In Yast look at the NVIDIA files make sure they match and reference the write kernel flavor. Assuming GO3 driver flavor then there should be 5 packages.

Thank you very much for the reply. I think maybe there’s a hardware problem. I downloaded the 13.2x64 DVD iso and burned it to a thumb drive, the booted into memory check (all 8 cpu’s on my AMD FX 8350 running at the same time, stock clock) with no errors. When I try to run the “check installation media” it loads the linux kernel, but hangs at:

starting udev...
    1.759400]  microcode: CPU2: patch_level: 0x06000803
    1.759511]  microcode: CPU3: patch_level: 0x06000803
    1.760609]  microcode: CPU4: patch_level: 0x06000803
*(this is where it hangs)*

When I try running the installer, it hangs at almost the same place - but gets as far as CPU6 … OTOH: running the memtest on the installer with all 8 CPU’s (in parallel) throws no errors so I think the CPU isn’t the problem.

So, I once before had one of the AMD super processors (a Phenom II black as I recall) which had one of the two memory channels bad, but that was bad out of the box - this just started, unannounced, a few days ago… Could be a bad motherboard? Does this look at all familiar to any hardware wizards?

When I actually try to boot 13.1x64 (which is installed on the HD), it hangs with some USB errors. It will boot KDE in Failsafe mode, but refuses to recognize the keyboard or mouse. So I’m thinking maybe a MOBO problem. But why, then, the hang on udev above?

Thank You, Patricia

Well check media does not work reliably on non-dvd/cd media.

Hardware can cause odd problems. Had a Video card go bad and it caused alsorts of weird problems before it totally crapped out

Hi G. Thanks for the reply!! Ah, OK - I guess change some video cards is worth a try. It is a relatively new video card (a couple of weeks old - could be an early failure). But have you ever seen the freeze thing at the CPUx microcode checks? The only time I’ve seen something similar was with a bad SuperMicro motherboard (but it was bad OOB). Maybe I’ll try, just for grins, the 12.3x64 DVD.

It seems like the last few years that things (mobo’s, cards, CPUs) have been getting less reliable OOB. I guess that makes sense as new factories have been opening up all over the world to make these things.

I had one fail in 3 months though it was one of the dirt cheap ones ie less then $30.00 not worth the hassle to get a new one. I then found a nice gtx 630 NVIDIA from Asus that has no fan just a honking big heat sink. I figure that a plus since the whole change of events started when my trusty 6800+ NVIDA’s fan died after 6 years.

Tried 3 PCIe video cards, same result. Voltage test, 5.11VDC and 12.14VDC. Hmmm… must be a bad mobo, chipset, or CPU.

OK, swapped motherboard, reinstalled NVidia drivers manually, and all is good. FWIW: it was throwing USB “-55” errors on the old mobo and wouldn’t recognize the keyboard or mouse. I’m thinking “chipset.” So many things can go wrong. I have fans all over my chassis, and filters on the air entries. :slight_smile:

…actually, I swapped the motherboard and CPU (swapped the HD and memory to another box, actually). I burned a DVD of 13.2x64 (I was warned earlier in this thread that there might be problems with a USB stick) and the installer still hangs at the microcode check. This time it hangs at CPU2 (of the 8 in my FX). This seems highly odd. The memtest on the CD does not throw any errors, even with Parallel CPU mode (testing all CPUs simultaneously).

These 4 boot options are present in my current 13.1x64 install:
3.11.10-25 (Failsafe)
3.11.10-21 (Failsafe)

…only the last option will boot successfully to KDE. The others complain or hang or go nowhere looking for nouveau, even though I have the NVIDIA driver installed (the hard way). I don’t really understand why one of the above should boot and the others not - do they all use different xorg.config’s?

So my fix was to simply do a fresh install of 13.2 rather than getting tangled in drivers, but I ran across this installer bug… Ideas? I was thinking I might simply boot to 3.11.10-21 and do an online dup if the installer wont’ work, but if the installer won’t work, there might be a reason that would prevent 13.2 from working.

OK, I figured out the installer thing, at least the DVD version of it (don’t know why the USB stick .iso would hang - I burned it with opensuse studio writer). It was a BIOS thing - this BIOS detects both an named (model number) version of my CD/DVD writer and generic CD-DVD device. When I switched the primary boot from the named version (LS120) to the generic CD-DVD in the BIOS, then the installer did complete its boot cycle (without having to invoke F12 boot menu during boot) and now the 13.2 installer is working. I guess the installer code can get device-confused.

But the installer display looks like 800x600 expanded (pixelated) - with vertical lines going through it. Video card is pretty new… EVGA GTX760Ti… try another video card… switched to older Zotac GTX650… Well, now the installer looks OK. So, my problems in this thread all started a week or so after getting the EVGA GTX760Ti - coincidence? It works fine most of the time, but there are obviously some sort of issues. Thoughts?

(Note that this is separate from the nouveau issue above - I think I borked the drivers.)

I wonder if there are known issues with these GTX7**Ti series cards? Since it actually “works” - I can’t really return it. It just has some weird issues. So maybe it’s a brand name problem? Unreliable card with Opensuse?

I believe the normal NVIDIA driver from the repos will not work with that card (at least not yet. You will have to install driver via the hardway for now. There is apparently one on the NVIDIA site.

Thanks g.:slight_smile:

I don’t really understand the various video subsystems code-chunks (modules?). There are several important parts to the display; nouveau, Nvidia driver (or not), X-driver, (maybe more - is there a nice discussion of this on the support pages?). The only way I know to get a functioning system is to either just use the default (nouveau, right?), or else install the NVIDIA***.run driver from console, starting from the default state. I don’t know how to return to the default state other than a reinstall - I don’t know enough to do it with just YaST. What I gather from the forum is this is “tricky.” :slight_smile:

BTW: Is there an appropriate thread for multiple video cards? All I can find is a discussion of multiple displays (on multiple cards). I’m using the multiple cards for GPU only - and only a single display. (So the other video cards aren’t carrying display, just doing CUDA calculations - that’s why I installed the NVIDIA driver from the NVIDIA***.run file.)

Thank You!

AFAIK the SLI configuration is supported transparently via the proprietary driver. Don’t know if the OS driver supports it.

Isn’t SLI a way to link graphics cards together for multiple displays (EDIT: I guess I should say “for display purposes”)?
(from wiki) “SLI allows two, three, or four graphics processing units (GPUs) to share the workload when rendering real-time 3D computer graphics.”

I’m doing CUDA calculations for computational fluid dynamics, etc., so I don’t think I need SLI. Each card acts separately.

BTW: HAPPY NEW YEAR!!! :slight_smile:

Hi G: :shame: Wow - you are NOT going to believe this - this entire thing may have been about video cards. I put a GT730 (PCIe x1) into the computer and now everything boots normally. No more wierdness at all. Ummmm… so I guess you’re right about lack of support for that newer card.

Since I want to run several cards, do you know if there is there a way to tell opensuse which card to use for KDE - the others are only there for GPU computing (mathematics - BOINC) and should be ignored by the display.

What I’ve noticed so far is that opensuse finds the first video card in the lowest-numbered PCIe slot, but part-way through the boot process, if it finds a faster card in, say, a x16 PCIe slot, then it will switch to that one. So I need to tell it to stick with the first one. I guess the hardware manager will tell me the slot number, but I’m not sure what command (in which file) will force use of that slot number.


I think one of those time you need to actually ask NVIDIA. You are running out there on the edge :stuck_out_tongue:

It doesn’t feel like the edge… :shame: …maybe this is why I think I’m a bug magnet…

Well you are working with some serious hot machines. Think Ferrari. rotfl!

It is possible, but it would take manual configuration of the Xorg configuration files (located in the /etc/X11/xorg.conf.d/ directory), so it’s not for the faint-hearted, and may need some tweaking to get right.

You’d need the Bus ID information from ‘/sbin/lspci’, then create, device, screen, and monitor sections sections like shown in the ArchLinux wiki eg /etc/X11/xorg.conf.d/40-custom.conf

  • Ignore the TwinView example and look at the next

You might only need to define the primary card for the X-server, with one particular Bus ID referenced. I can’t test this as I don’t have the required hardware.

Hope that gives you the basic idea.