GRUB_MODE has no effect on tty1 to tty6 consoles


I follow here malcolmlewis:

I do it here:

As can be seen in the following threads:

my problem is to get the console resolution in YaST control center => System => Bootloader => Kernel-Parameter;
here: Grafik-Konsole (checked!) with
GRUB_GFXPAYLOAD_LINUX=keep <== and it does not keep it!]
in /etc/default/grub
shurely to the tty1 to tty6.

I fear that this problem is still present as a bug to solution since years:

Is ist so? Then I have to wait patiently for a solution of the experts.
Or have Linux experts really a solution of my problem?

Thank you for the commitment,

So when you boot with the nomodeset option, what driver is in use?

hwinfo --gfxcard

Or is it still the nouveau driver?

Yes, as you can see:

36: PCI 300.0: 0300 VGA compatible controller (VGA)
[Created at pci.328]
Unique ID: svHJ.wmhO879R1oD
Parent ID: 3hqH._4Jk6Hys5IC
SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: graphics card
Model: “nVidia GF100 [GeForce GTX 480]”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x06c0 “GF100 [GeForce GTX 480]”
SubVendor: pci 0x10de “nVidia Corporation”
SubDevice: pci 0x075f
Revision: 0xa3
Memory Range: 0xf8000000-0xf9ffffff (rw,non-prefetchable)
Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)
Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)
I/O Ports: 0xcc00-0xcc7f (rw)
Memory Range: 0xfbc00000-0xfbc7ffff (ro,non-prefetchable,disabled)
IRQ: 10 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v000010DEd000006C0sv000010DEsd0000075Fbc03sc00i00”
Driver Info #0:
Driver Status: nouveau is active
Driver Activation Cmd: “modprobe nouveau”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #11 (PCI bridge)

Primary display adapter: #36

Or is the proprietary driver from NVIDIA a better choice?

I tried in with my notebook:

YaST => System => Bootloader => Kernel-Parameter => Use Graphic console (checked)

all choises:

automatically detected by grub2

There were no visible changes, neither in X11 desktop nor in tty. Why such offer
for nothing?

It is not for nothing.
It just changes the bootmenu’s resolution only (that’s why it is in the Boot Loader settings).

This resolution should be taken over to the text mode consoles, but apparently it is reset to your monitor’s native resolution during boot.
To prevent that, you’ll have to set the “nomodeset” boot option.
In the case of the fbdev driver (which should be used by default when sepcifying “nomodeset”) this is even carried over to X.

And yes, I just tried it. This works that way here.

“nomodeset” of course prevents the use of KMS video drivers, nouveau in your case.
So you definitely should install the proprietary nvidia driver, then you won’t even need “nomodeset” for that resolution setting to have effect AFAIK (haven’t tried that on 13.2 yet though, only upto 13.1).

The X settings are normally independent though, in the case of the nvidia driver you can change them with nvidia-settings, or you could change them in your desktop’s settings in any case.

PS, I forgot:
For KMS drivers like nouveau, you can change the text console resolution via the “video” kernel boot option.


No need for “nomodeset” then.

I tried this here as well, and it works fine with radeon. Even after logging into X and switching to VT1-6 via Ctrl+Alt+FX.

But, again, this has no effect on your X session, you have to change the resolution for X in X’s or your desktop’s configuration.

“You have to learn the rules of the game. And then you have to play
better than anyone else.” (Albert Einstein) You did it, wolfi323!
My sincere thanks,