Grub Error - Cannot install onto SATA drive

Hi all,

I am trying a fresh install of Opensuse onto this setup:

AMD 4400+
4 GIG Ram
SATA Optical DVD drive
36Gig WD Raptor SATA HD
ASUS Motherboard

Anyways, I have tried Opensuse 11.064bit/10.364bit/11.032bit DVD’s and I get the same error, about 3/4 of the way in, during boot manager install, I get a “Grub Error”

What do I need to do to install?



during the setup for install, when the install summary comes up but before the install starts, have you clicked thru to grub to double check the settings and location?

No I haven’t,

I will go do that right away and see what it says.



This is what is says:

**Boot Loader: Grub
Location: /dev/mapper/nvidia_ababifh(MBR)
Selection: opensuse10.3(default); Failsafe opensuse10.3
Added kernel Parameter: splash=silent

I don’t understand about the partitioning though, it mentions raid nvidia partitions, I don’t need raid, it is a single drive, and my mobo is a ATIchipset (ASUS M2A-VM) with onboard ATI video (X1200)


Did you try and change the location?
Check what the partitioner section says about the ID/label of the HD
ie: sda1

Okay, BRB


WHOA!!! Thanks a million,

You told me to read the partition section.

I went in there, I actually read the sizes of the nvidia raid partition sizes, then went into edit and deleted all the nvidia raid partitions, and I created new ones by myself,

Never thought I could do this myself.

I created:

/boot 70Megs
swap 2Gigs
/ 13Gigs
/home 20Gigs

Now when I check the checklist, grub says it is installing into /boot sda1

Thanks a million,caf4926


Happy it worked out for you

I owe you a beer, dude.

Thanks, It installed nicely now.