gripe: suspend to disk or ram

Forgive me if I’m a bit irate at the moment - but I am rather PO’d with openSuse’s inability to suspend to disk/ram.

It should either work - or not work - but definitely not somewhere in between.

In general, when I close the lid to my laptop, it will suspend to disk (suspend to ram never worked). Upon restoration, it is fine most of the time, although on occasion I have a “failed to suspend” error message - but obviously it didn’t fail because it did suspend to disk and power off.

However, if I suspend to disk again - there is an increasing chance it will fail to restore itself without needing a reboot. I don’t think I have gotten it to suspend to disk more than 3 times in a row - when it “fails” it comes up with a black screen and I am forced to just power off/on.

However, here is my gripe … when it DOES suspend to disk correctly - it takes FOREVER. Sometimes on the order of 1-3 minutes. That is insane. Just this afternoon, I had to grab my laptop and go - so I closed the lid and slid it in my backpack - I didn’t have time to wait to make sure it suspended to disk. Hours later … I noted a little noise - you guessed it - the computer was ON and HOT as hell.

(hence my terse post here).

So … I need to find a solution - or else, totally disable this “feature” because the risk of it not working and cooking my machine is too much. It makes me wonder - how often have I left the machine in my backpack, all zipped up and cooking, while the battery runs itself out? I guess - I am saying:
lid closed should = suspend or power off or shutdown - but definitely not stay on (unless, of course, the user has selected that as a choice).

Ok … I guess I am off to read all the posts about where the problem is and try to track down a solution.

sorry for being so irate - but if anyone has any solutions - or can point me in a direction to look - that would be much appreciated - but for now - I don’t trust suspend to disk with openSuse at all …

I always prefer the suspend to ram option on my laptop.

it takes a bit of reading to get it working right away but it is definately worth the time put in

Learn about using zypper if you like to do updates and install packages from the command line rather then using the Yast tool for that

Zypper/Usage/11.0 - openSUSE

Thanks, I’ll check out Zypper. I’ve been using the Smart manager and have been (relatively) happy with it.

When I get the time, I’ll dig deeper into getting suspend to ram/disk to work better.

Suspending to ram would be great - thats what my desktop does and it is wonderful.

Start checking suspend operation with

s2ram -f

If this fails, look for errors in /var/log/pm-suspend.log

Good howto here:

Suspend to RAM - openSUSE

Sometimes, network and graphics hardware can be problematic, but there are workarounds.

Under the various tricks FAQ part especially look for pm-utils on OpenSuse. This calls s2ram

Pm-utils - openSUSE

If you get it to work on that s2ram that someone mentioned then to get it to work all the time as suspend to ram look at this section under the FAQ to make it work all the time

If you want to force suspend to RAM, you need to add -f to the S2RAM_OPTS-Variable in a configfile in /etc/pm/config.d/, see Configuration. You also need to put all other options that you need for your machine into this variable. An example might be:
S2RAM_OPTS="-f -a 3"

It might be a good idea to report your machine on as described in the s2ram-Page, so that you do not need to do this in the future.

Basically as root figure out the s2ram options that work from that link the previous poster mentioned, then when you find the combination that works for you lapto put it in the file listed above under that line S2RAM_OPTS with the option combination that worked for you

It would help to remember that often suspending to ram or disk is not enabled by default, because the developers don’t whitelist machines that they don’t know for sure will suspend correctly. This list tends to be smaller than we like, since the developers don’t have all the info they need about the capabilities of machines (closed specs/bioses, etc.).

Every machine I have installed on in the last few years has been capable of suspending to ram (s3). I have been able to add that option to each machine.

That’s true - I did have to enable it. I guess the onus of responsibility was for me to verify it worked as expected.

Thanks everyone for the leads - I will pursue them when I can over the next few weeks and report any specifics (with my laptop make/model) here for any else with this problem.