Greek keyboards - accents not working


I’ve a fresh install of Tumbleweed in a Dell XPS 13". I added the layouts and the languages I use and I’ve configured the switching shortcuts. It seems however that for Greek I can’t seem to write the letters with accents, although I can write Greek letters. For example, I can write

α, ε, υ, η

but not

ά, έ, ύ, ή. This was happening only in applications like OOffice, kwrite, kate, texstudio (for writing latex), etc., but not for Chrome or Firefox, where I could write Greek just fine.

I installed the ibus package which installed another application in the taskbar and now I can write Greek correctly. Why is this so? Is this the correct way to support additional keyboards? I know have 2 indicators for the active layout but the one from ibus does not change as I shift the languages. The default one does and the keyboards are fine. Is there a way to keep only one of the two options?

First of all, which desktop environment are you using, KDE or Gnome?

Are you using an English keyboard or a Greek keyboard?

Finally, take a look at this app:

This will give you a keyboard on your screen. If you still can’t use Greek diacritical marks in LibreOffice or some other apps even when using the on-screen keyboard, that is probably a bug.

Thanks for the reply. A few info for my setup


KDE Plasma: 5.8.4
KDE Framework: 5.29.0
Qt: 5.7.1
Kernel: 4.9.0-2-default

Not sure what you mean by keyboard layout. I use three layouts, German, English and Greek. German special keys work fine, e.g., äöüß. Only issue is with Greek accents. **After I installed the ibus package though I have a correct mapping for all characters, however it seems that in the taskbar I run two apps for the layouts, one offered by ibus and the other is the default. **