graphics not working for Vaio (intel chipset GM45)

Hi all,

I was wondering if anybody can help on X Window graphics on my Sony Vaio (VGN-SR90S) machine. After startx the screen goes blank, and though I tried various settings on xorg.conf I can’t bring it to work. In particular this vaio has a 1280x800 resolution, and I configured it as such.

This machine uses an embedded graphics card in the Intel Chipset GM45, which is quite new, and seems to be causing the problem. I downloaded & installed some driver rpms for this chipset but still no luck.

I may be too brief but don’t really want to inundate you with xorg settings and so on, quite yet.

Any suggestions would be appreciated. Maybe there’s somebody out there who has the same chipset with OpenSuse, and perhaps encountered/solved the same problem?


I have this issue as well, I’m going to link you to my thread in the fedora forums (which in turn links to the xorg bug upstream). If you have seen/heard any solutions to this please let me know, and if I hear anything I’ll post it back here as well.

PS… is there a build service repo anywhere with the latest versions of the drm modules and the intel driver? Or better yet, even a GEM patched kernel?

EDIT: Oops, sorry… forgot the link: Intel GMA 4500HD -

Same problem here, with a Vaio SR39XN.

I have been trying to find out an easy way to solve it but no luck so far :

  • the stable packages hang on a blank screen
  • the packages from the X11:XOrg repo work but are totally unstable on my system (issues with the French keyboard, virtual terminals not working…)
  • the packages from Factory behave the same as the stable one

I will try to figure out how to set up the drivers from there Intel Linux Graphics: 2009Q1 and update here if I succeed.

Well, one week after, I haven’t been able yet to make neither the xorg-x11-video-drivers work nor the intel sources compile.

Has anyone ever succeeded ?

****, I chose this laptop for a relative thinking that it would be straight forward with an intel chipset, what a shame if I can’t set it up.
I regret now that I didn’t buy one with a nvidia or ati card…

I finally got the driver from X11:XOrg:sle11 to work.

However, I have to deactivate the 3D acceleration with this in the device
section :
Option “NoAccel” “true”

If I don’t, the X server hangs with :
(EE) intel(0): Failed to pin back buffer: Cannot allocate memory

For those who are interested, I reported a bug :