Graphics card Malfunction Problem with glx.

I was looking to get glx to work with direct rendering. So i installed the nvidia drivers from the openSuSe Sight. I installed because /var/log/Xorg.O.log Said that the Nvidia card was not loaded. Long story short looks like the card is loaded but X windows… I guess GLX is not running and neither is Opengl. I still have output to the monitor.

here is

glxinfo

name of display: :0.0
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
Error: couldn’t find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension “GLX” missing on display “:0.0”.
Xlib: extension “GLX” missing on display “:0.0”.
0x5d 32 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

Here are some of the errors from Xorg.0.log

(II) LoadModule: “glx”
(II) Loading /usr/lib64/xorg/modules/updates//extensions/libglx.so
dlopen: /usr/lib64/xorg/modules/updates//extensions/libglx.so: undefined symbol: _nv000070gl
(EE) Failed to load /usr/lib64/xorg/modules/updates//extensions/libglx.so
(II) UnloadModule: “glx”
(EE) Failed to load module “glx” (loader failed, 7)

please email how to clean up this thread with text boxes. Is it java script? tomjbowman@gmail.com

Info
–Sorry I forgot to add the version of Open suse, which is 11.2.

–I am running this on a HP Pavilion dv6000.

–The graphics card 256MB NVIDIA(R) GeForce(R) Go 7200.

–The file “/usr/lib64/xorg/modules/updates//extensions/libglx.so” does exist.

–Even if the instruction is to do a fresh install any reply would be welcome.

You should not have this sort of problem. Hence it suggests to me there may be something unusual in your setup. Please post here the output of:

zypper lr -d

did you install the driver provided by opensuse or the proprietary nvidia driver?

i had an issue with the built-in driver at installation, there was something weird with the output and 3d games.

so i went and installed the nvidia driver 190.42 linux x86 from the nvidia webpage the “hard way”, now easy for me after doing it many times in all the years with opensuse and SLED (from the command line).

no need to say that the drivers from nvidia perform better for 3d games, of course, it’s their software…

my suggestion is to install the nvidia driver provided by nvidia. it might resolve your issue (the current version is now 190.53; though i’m very happy with 190.42).

donwload it from this site:
Unix Drivers Portal Page

hope this info helps…
<OF>

graphtjb@linux-9sir:/usr/lib64/xorg/modules/updates/extensions> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±------------------------------------±----------------------------±--------±--------±---------±-------±----------------------------------------------------------------±-------
1 | NVIDIA Repository | NVIDIA Repository | Yes | Yes | 99 | rpm-md | ftp://download.nvidia.com/opensuse/11.2/ |
2 | http-download.opensuse.org-2d5aca65 | Updates for openSUSE 11.2-0 | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
3 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
4 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
5 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
6 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
7 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |

Sorry this is hard to clean up.

Those repositories actually look ok.

Repository Recommendation. You could disable #1 and disable#3 for now. (Do that under YaST > Software > Software Respositories). You could also add Packman (and only Packman, NO OTHERS) and do that per the guidance here: Repositories/11.2 - openSUSE-Community

The advice of ofvergara may indeed be the way to go. But before you do that, you could try a couple of things, in case those errors that you posted are misleading (because I don’t understand them).

nVidia Graphic card practical theory. Note that for nVidia graphic cards, you have some choices for graphic drivers:

  -  **fbdev**
  • this is the frame buffer driver and it is compatible with many different graphic cards (ati, nvidia, intel … ) . It has the slowest performance, but sometimes it will work when all else fails. It typically comes packaged with openSUSE as part of xorg-x11-driver-video rpm. - vesa
  • this is the vesa driver and it is compatible with many different graphic cards (ati, nvidia, intel … ) . It is faster than the fbdev for performance, and it is pretty robust, but overall it still has slow performance. It typically comes packaged with openSUSE as part of xorg-x11-driver-video rpm. - nv
  • this is the free open source nVidia driver for all nVidia hardware. This driver should have much better performance than the VESA driver. It typically comes packaged with openSUSE as part of xorg-x11-driver-video rpm. - nvidia
  • this is the proprietary free (as in free beer) nVidia driver for the latest nVidia hardware. This is the one you tried to use and failed. For nVidia hardware it should have better performance than all other drivers, but it tends to be a fragile driver and many times a kernel or an xorg update will break it. In order to install it one must download it from the nVidia web site (or from a special repository which is what you tried) and then do various hand tweaks to get it to work. It does NOT come with openSUSE.

xorg.conf file in Linux. In older openSUSE releases, it was necessary to have an /etc/X11/xorg.conf file which defined the configuration needed for one’s graphic card to work with one’s PC’s hardware.

As of openSUSE-11.2, the need to have an xorg.conf file was removed for many graphic cards. This was because “xorg” who code X window framework are moving away from requiring the xorg.conf file, but rather want to have the card configured automatically without that xorg.conf file. In such a case, the xorg software should automatically use the latest open source driver (i.e. “nv”). However the automatic recognition of graphic cards is still not reliable for all cards in openSUSE-11.2.

In that case (where automatic graphic card recognition fails) one needs to create an xorg.conf file for the card to force a configuration, for if that xorg.conf file is available, then the xorg software will use it.

Software to Create xorg.conf file. There is software provided by nVidia (comes with their driver) that can be used to configure the proprietary driver and create an /etc/X11/xorg.conf file. This package is called “nvidia-xconfig” . One should run that program from “run level 3” (more about “run level 3” later) with root permissions.

There is also software provided by SuSE-GmbH in openSUSE that is used to generate the xorg.conf file for graphic drivers, which is called “sax2”. One can run “sax2” with many options (but it must be run with root permissions).

For example, to check what chip# one’s graphic devices are, one can run with root permissions:

sax2 -p

pay attention to the chip, … ie chip 0 (typically if only one graphic device) or there may be a chip-0 and a chip-1 (if one has more than one graphic device).

Run Level 3. Now typically, when reconfiguring a graphic card, it is best to do this NOT in X window, but rather in the full screen terminal run level 3. One boots to run level 3 by pressing “3” (no quotes) when the initial grub boot menu first appears. By pressing “3” one will see the “3” appear in the options line. Then boot normally. That brings one to a full screen text login. Login as a regular user.

Creating the xorg.conf file After logging in to run level 3, type “su” (no quotes - enter root password) to switch users to the administrator/root. If one wishes to force sax2 to create an xorg.conf file for the open source graphic driver (called “nv”), then one would type in run level 3 (NOT in X window):

sax2 -r -m 0=nv

or

sax2 -r -m 1=nv

where the 0 or 1 depends on what graphic chip one is trying to configure. The “-r” option tells sax2 to ignore any previous created xorg.conf file, and overwrite/replace it.

If one has the proprietary driver installed (via the proprietary rpm) one could tell sax2 to use that driver when creating the xorg.conf by typing:

sax2 -r -m 0=nvidia

or change the “0” to a “1” if one’s graphic card is chip-1.

If one has the proprietary nVidia driver installed (via the rpm) and one wished to use the nvidia software (instead of sax2) to configure the proprietary nvidia driver and create the xorg.conf file, one would type:

nvidia-xconfig

Once sax2 or nvidia-xconfig is complete, one can restart from run level 3 by typing “shutdown -r now” and then let the reboot continue to see if the graphic card configuration worked.

Now as noted, one can install the nVidia driver via the repository/rpm method (which you tried to do and failed) or one can download the proprietary driver as a binary .run file and install the driver by running that binary as suggested by ofvergara. This is called “the hardway” and it is NOT hard (that is the way I always do this). There is more guidance on this “hardway” here: NVIDIA/The hard way - openSUSE Note installing the hardway means one is building the driver on one’s PC, in which case one needs gcc (ie the base developement pattern) and also kernel-source, kernel-syms and linux-headers installed.

Hopefully that gives you a bit more information so that you can understand the recommendations that have been given above by other forum members.

Geforce Go 6150 for a laptop computer. The “Linux x64 (AMD64/EM64T) Display Driver”, from the Nvidia site, only contain the card Geforce 6150 and GeForce 6150 LE. Should i still attempt the hard way or should i try to install one of the lesser drivers?

Thomas

You may want to use the legacy driver with that one check the NVIDIA site for the legacy cards.

When i typed in Geforce go 6150 I found only windows vista drivers.

I found more references to a “GeForce Go 6150 / nForce Go 430” which i can not tell if this is my card.

From what i can tell there is no legacy driver for my computer.

“This is the evidence”

This is the search for geforce go 6150 and linux
Search NVIDIA

The search for geforce go 6150 and unix yeilded no results.

The archive yields nothing.

This is the page i get for my video cards name.
Tech Specs

The X windows come up so i have KDE. I am typing this in firefox, but glx is not working. Some sort of driver is working for the OS and the hardware, but glx or xgl is not working.

Looks like that card is supposedly supported in the current driver. But the early go cards always seemed to be a problem. You could try the older driver it may work ok may not. Be prepared to rescue from the command line if per chance it would not work at all. I’d try the 178.xxx.xxx

Be sure to get the right one for your OS ie 32/64 bit

You will need to install the kernel-source and the gcc compiler to install the “hard way”

Unix Drivers Portal Page

instructions here

Nvidia Installer HOWTO for SUSE LINUX users

Note there are no instructions for 11.2 but just follow 11.1 and remember that you are installing a different driver version adjust numbers as needed

I have attempted the hard way. GLX does not seem to work in any case.

I downloaded the kernel-source, kernel-syms, make, gcc.
I enabled the nvidia software resource which i hope was gogalthorp’s advice.

I went into level 3 and typed nvidia-xconfig. Program configured. Glx did not work.

I went into level 3 and typed sax2 -r -m 0=nvidia. Program configured. Glx did not work.

I went into level 3 and typed sax2 -r -m 0=nv. Program configured. Glx did not work.

I went into level 3 and typed sax2 -r -m 0=fbdev. Program configured. Glx did not work. Everything in glxinfo is zeroed out.

Side note : At some point Glx had a reference but no ability to direct render/hardware acceleration. I then installed the nvidia drivers and some is now mis-configured or unaccessable by the driver.

If i am not wrong fbdev was the all else fails driver. Is it possible that something else is mis-configured that stops glx from working.

Thank you for helping this far.