Graphical applications hanging - via ssh

Dear all!

When I connect from a PC with openSUSE Leap 42.2 (sddm as displaymanager) to a server with SLES 12 SP2 some applications hang during start there. These are eog, evince and libreoffice. For eog and evince I found the workaround that I installed gdm and activated this displaymanager. But this is no workaround for libreoffice. After starting only the splash screen occurs and the application is hanging. I could start libreoffoffice when I connected from a PC with Leap 42.1 to the server with SLES 12 SP2. I also tested the following scenarios:

  1. ssh connection from PC with Leap 42.1 via PC with Leap 42.2 to
    Server with SLES 12 SP2 -> loffice started successfully
  2. ssh connection from PC with Leap 42.2 via PC with Leap 42.1 to Server with SLES 12 SP2 -> loffice was hanging after start

I would be deeply grateful for any help.



Although other display managers <may> work,
The general recommendation is to use the Display Manager “lightdm” to support remote connections.

Also, you need to install the xorg x-server.
The easiest way to install everything you need is to use the Remote Administration module in YaST to install VNC. After that, you don’t have to use VNC, you can run any other kind of remote graphical console like X over SSH if you wish.


Thank you for your hint. The package xorg-x11-server was installed yet. After installing and activating lightdm and rebooting I tried it once more. The applications eog and evince worked but not loffice. It was hanging again.


Try a “cold boot.”

A cold boot is when you power off completely, wait about 30 seconds before powering up again.

If you simply do a “restart,” that is commonly referred to as a “warm boot” when stuff might still be in memory (not cleared out completely) on reboot.


Sorry for late answer and thank you for your tip.

Unfortunately the coldboot did not lead to a success but I found another solution. In /etc/ssh/ssh_config I disabled the following option:

ForwardX11Trusted yes

The command “ssh -Y …” is still not working but is not a problem for me.

A side effect is that connecting to this PC is only possible without X forwarding but you can enable it by adding the following line into /etc/ssh/sshd_config and restarting the sshd service:

X11Forwarding yes

Conclusion: I suppose a bug in openssl.

It seems I made a mistype. I mean a bug in openssh or in an appropriate package.