Graphic and Software Behavior

So… It’s been a while (1.5 year ago) since I first started using openSUSE and I enjoy it most of the time.
But when trying to do some real work regarding graphics in software such as Inkscape or Draftsight, I don’t get expected results. By that I mean, moving object on canvas is Herculean job. Elements are tearing, it is very slow… Bottom line I can’t do anything except surfing the web, watching videos and listening music.

I’m using PC with i3 processor, radeon hd 5450 graphics with proprietary driver installed. Everything seem to work fine, with or without graphic driver installed, but when it comes to dealing with graphic software, it’s just so sad… I tried tweaking AMD Control Panel, but no success.

With having in mind all given facts, I’ve been wondering what’s the essential problem with graphic software so it won’t respond in expected way? Or I have that problem only…

I’ll suggest something is not optimally setup on your PC.
I have run gimp, inkscape, QCAD, Draftsight and other graphical applications with very good results, on platforms less powerful than i3.

For starters and best help here, you need to be a bit more specific on what version openSUSE you have installed.
32 bit or 64 bit?
Did you install inkscape from a repository or compile?
It might also be helpful to mention how much RAM you have, if you are playing with big files RAM will make a difference.

For starters, try starting an offending application from a command prompt in a terminal (konsole) window.

carl@PVE-LinuxSRV5:~> inkscape

Frequently, if the application is having issues with files or libraries, messages will appear in the CLI window while you are working in the GUI window.

Well I run 32 bit version of openSUSE 12.2, with 4 GB of RAM installed.
I didn’t compile any of my software, and I don’t get any error messages either way I start my programs.

I had the same problems in Ubuntu as well, but after trying various distros, I realized openSUSE does the best job.

Is there anything else that I maybe missed?

I am not real familiar with i3 hardware.
Is this a laptop or desktop?
If it is a laptop, is it a “dual graphics” architecture (native Intel plus AMD/ATI or Nvidia, AMD/ATI in your case) ?

If yes, you may want to head over to the hardware forum, lots to read on issues with dual graphics setups.

It’s a desktop, sorry I forgot to mention about it…

Hmmm, does the graphics card have its own ram or is this a “shared RAM” setup?

I had at one time issues that seemed bios related, where graphics would not run well with certain sized shared memory spaces but OK with others.

How did you install the radeon driver?
On my ATI systems, I use please_try_again 's atiupgrade script to keep all the moving pieces currrent.

On 01/11/2013 05:36 PM, thermooo wrote:
> I run 32 bit version of openSUSE 12.2, with 4 GB of RAM installed

which kernel are you running and is all memory in play?
to answer, please show us the output of these commands, inside code tags
as explained here:

uname -a
free -m


Here’s an output

aid@linux-t1mh:~> uname -a
Linux linux-t1mh 3.4.11-2.16-default #1 SMP Wed Sep 26 17:05:00 UTC 2012 (259fc87) i686 i686 i386 GNU/Linux
aid@linux-t1mh:~> free -m
             total       used       free     shared    buffers     cached
Mem:          3534       3249        284          0        119       1667
-/+ buffers/cache:       1462       2071
Swap:         2050          0       2050

It has its own RAM, 1 GB

I installed it over: SDB:AMD fglrx - openSUSE Wiki
It’s a one click install.

Hmmm, one has to wonder a bit if you have hardware problems with the card, given that Ubuntu had same sorts of issues.

Does glxgears run smoothly?
It is not a comprehensive test, but a reasonable go/no-go

carl@PVE-LinuxSRV5:~> glxgears
14461 frames in 5.0 seconds = 2892.106 FPS

At one time I thought the SDB method of install was broken, but that is long ago.
Do a forum search on atiupgrade, it is an effortless way to avoid most ATI driver pitfalls.

One thing you might try is to switch to the openSUSE radeon open source driver rather than the proprietary driver.
It seems to work OK for most nominal applications.
Drag a square around on Inkscape should not be a huge graphics load.

For reference, I am running the AMD proprietary driver
AMDCCCLE(Catalyst Control Center) reports Driver Package 9.002-120928m-148573C-ATI, 2D Driver 9.0.2, OpenGL Version 4.2.11931

Surprisingly, everything else on the system works perfectly. After installation of graphic driver in your way, everything is basicly the same…

I believe it’s the problem with software and not the system or graphic driver cause when I install Draftsight and Sketchup for Windows over Crossover, it works as if I was using it on Windows… No problems at all…
Also, once I tried Inkscape on a Debian 6 (we know how they’re working on its stability), and it worked flawlessly… Those are my experiences… I just hoped to get rid of Windows tail that’s everywhere…

On 01/11/2013 06:06 PM, thermooo wrote:
> linux-t1mh 3.4.11-2.16-default

i’d suggest you try the desktop kernel…
might not help, but do not think it could hurt…
it will, of course, require the video driver be rebuilt for the kernel…


Another diagnostic idea - If you don’t have one already, install a System Monitor App or Widget.
I use Ksysguard.
Configure it to display CPU load(s) and clock. Leave it open on the desktop.

Open Inkscape, draw a rectangle, select it and drag it around the screen.

Does the CPU in use pin at 100%?

I see the CPU shift into high freq (max) but no more than 30-40% use.

Other thoughts - following on DD’s comment about desktop kernel:
What does the default kernel setup display under System Settings - Hardwrae-Power Management?
Any chance you are running in a “low performance” mode and don’t realize it?

Guys, I installed desktop kernel and now it’s much better. Graphic driver is installed again. Moving of elements is much smoother and better so it is possible to work with, but during the resize and moving, elements are tearing everywhere… No extra resources are used during usage of software!.. Also now kernel is not recognizing my USB devices so I have to re-plug it in everytime I boot up in order to make them work…

On 01/11/2013 10:46 PM, thermooo wrote:
> but during the resize and moving,
> elements are tearing everywhere…

try turning off desktop effects…if that solves (or almost solves) the
problem you have a decision to make: do you want tearing or do you want
desktop effects??

and, maybe you just need to turn them off when you wanna do GIMP/etc…
or maybe just turn off some of the more labor intensive

OH, and if you are streaming a youtube (or torrent, or or or) stop that
and see if the graphics works better…

so, the ‘trick’ is: Use what works. (or buy different hardware known to
work smoothly, while doing all you wish this one would do…)


I turned off effects, and it’s working like a charm… You’re my hero! Thank you!

One more thing, do you have any idea regarding fixing this desktop kernel or something cause now it doesn’t respond to my usb devices after booting up. I have to re-plug it in order to make them work.

On 01/12/2013 01:06 AM, thermooo wrote:
> do you have any idea regarding fixing this desktop
> kernel or something cause now it doesn’t respond to my usb devices after
> booting up.

please start a new thread with this problem, you can reference this
thread as background info:

when you post, please specify the “USB devices” not working (don’t make
us guess, please…and, always state the operating system and
version, the desktop environment and version…etc)


If disabling special desktop effects works, you could consider going back to the ‘default’ kernel where you know your USB devices worked. If you start a new thread, you may also wish to provide some info on the exact USB devices you are referring to.