Google Earth, Skype & Gnome questions

I’m having trouble with my openSUSE 12.2 64 bit quad core system running on an Asus M4A785M mobo with 8GB or RAM.

I found a thread talking about the same problems I’m having with Google Earth with the 12.2 RC1, but I’m running the stable release version I downloaded & installed on 10/26/2012.

I can’t seem to get either G.E. version 6 or 7 to run. After playing around trying to get all the 32 bit dependencies installed and still no joy, I removed G.E. version 7 (the latest as of this week) and installed G.E. 6 from YaST. I figure the 32 bit libs were OK to leave in place.

G.E. 6 starts to come up, but then crashes Gnome and I have to log in again. In fact it has altered my Gnome. It used to be that the desktop covered the entire desktop surface, and only 2 text items (Applications and Windows?) were visible. When you move the mouse over them or click them, the launch bar and vertical list of virtual desktops (on the right) become visible.

Now I have no launch bar and no vertical list of virtual desktops. Now there is a status bar on the bottom and a top menu bar.

What do I do to restore the old Gnome behaviour? I also installed Skype from YaST, but without a launch bar I’m not sure it installed correctly. I can’t launch it from the command line (it’s not in the path at least).

If anyone could provide some clues on how to go about resolving the Gnome issue I’d greatly appreciate it.

I’ve been using various Linux versions since 1995, but like everything these days things change rapidly and it’s hard to keep up. I’m actually quite disappointed with Google. They obviously didn’t declare the necessary dependencies for GE. Perhaps there’s a problem with the RPM package spec that allows the app to be installed with missing deps, but the more likely cause is the correct list of dependencies were not properly described in the package meta data.

Anyway, now I’ve got to unravel all this just because I tried to install an app. Talk about a productivity killer!

Try Cinnamon to get old wine(old menu etc) in new bottle(shell)

As you are using 12.2 this is not Pre-release/Beta.
As it seems to be mainly about 32 bit G.E. on 64 bit systems, I will move this to the 64 bit forum.
Please do not post here until moved.

Moved and open again.

I have the same sort of experience with GoogleEarth. I had the idea that I downloaded a 64-bit version of it, but on starting it (from a terminal so I couldd see whatt errors it gave) it asked for several libraries. I installed the 32-bit versions of them using YaST (a cyclic process, because after every install, it asked for a new one). After having solved these dependancies, it broke. I then deinstalled and tried a 32-bit version. It broke also (some SIGSEV or o). I gave up (II can live without it).

I am using KDE and KDE was not crashed as you report about Gnome.

You could check if Gnome is broken itself, or if you suffer from a broken user configuration by creating a new user and using that user with Gnome to see if all the parts are in order there.

you may want to try marble. This page says it is similar too google earth Marble - An Open Source Alternative To Google Earth [Linux]

Yes, this was exactly the approach I took with similar results.

I tried Marble (thanks for the suggestion), but find it has far less resolution and information.

Also, good suggestion on creating another login. If that restores the gnome behavior I expect I will focus on changes to .gnome config files in home folder.

I used ctrl-alt F2 to login as the new user, but when I tried to start another X session if failed. Any particular reason that isn’t possible?

Nope, should simply work.

Hm, something rotten there :frowning:

I logged out & back in as the new user. Upon logging in I received a notice that Gnome 3 failed to start and is running in the fallback mode. It suggested the graphics hardware or driver were not sufficient.

Yet that isn’t the case, as I was running in the “other” mode prior to fooling around with skype & Google Earth.

I don’t see a main icon for display under YaST, so the only way I know what driver is in use is to look under Hardware Information. Looks like it is simply “radeon”. The “save to file” option is worthless as a way to post the info here (it only saves the raw info from /proc it looks like. Only one match on “radeon” tho it appears in the hw / info gui several times).

The device lines read:
Device Identiifier: 104208
Device Identiifier: ATI Radeon HD Graphics

I used startx to start another X session on another virtual console. Is that the preferred method in openSUSE or is it initx?

Just discovered another anomaly: All youtube videos in firefox play at fast forward rate!


can you turn off hardware acceleration for
==>adobe flash player

Toggle both alternatively and check which combination works
How to Turn Off Advanced Graphics in Firefox |
Disable Hardware Acceleration in Flash Player