Google Earth Segmentation Fault

Hello,
A couple months ago I updated and could no longer run Google Earth. It shows a segmentation fault error. I updated G.E., and still receive a slightly different segmentation fault error (Different line number).
I’ve kept tumbleweed up to date, and just tried installing another new version of G.E., but no change.

I see posts from 6+ years ago w/ the same error. Having to do w/ video drivers. But, I doubt the solutions are relevant anymore.

Are others having this problem? Could anyone help me solve it?
(Experience level, lifetime of IT, but not a programmer, other than basic web/databse stuff)

-edit to mention, I’m using basic intel graphics… 630.

Thanks a lot!

Not sure if this is helpful but this is what I do to get GE to work. If I don’t do the following, I encounter many problems with installation and getting it to run.

For Google Earrth to work with TW, I always first install the Fedora 33 rpm for libmesa-libglu from pkgs.org. Then GE installs and runs great.

https://pkgs.org/search/?q=mesa-libglu

Thanks,
That got rid of the install error about mesa… But, I always ignored that error and it was fine. So, i did install mesa and it still didn’t work.
Mesa conflicted w/ libglu, but I told it to install anyway. Then GE threw a libglu error. I re-installed libglu and it went back to the segmentation fault error.

:~> google-earth-pro
/opt/google/earth/pro/googleearth-bin: error while loading shared libraries: libG
LU.so.1: cannot open shared object file: No such file or directory

:~> google-earth-pro
/usr/bin/google-earth-pro: line 21: 1000 Segmentation fault (core dumped) "
$(dirname “$(readlink -f “$0”)”)/googleearth-bin" “$@”

Hi
It’s known issue with Google Earth and the Tumbleweed version of curl, they need to fix/rebuild…

OK, thank you.

Anyone know if I can work around it? Revert to previous version of curl?
Maybe I’ll go make a little noise over on the GE forums…

Hi
Yes, but it’s a CVE security issue…hence the updated curl :wink:


rpm -q curl --changelog | less

Not sure if tumbleweed-cli would go back to before that date looking at the history repo: http://download.opensuse.org/history/

Heading to the GE forums would be best idea…

Try this :-

On Tumbleweed :-Get libcurl from
https://ftp.lysator.liu.se/pub/opensuse/distribution/leap/15.3/repo/oss/x86_64/libcurl4-7.66.0-4.14.1.x86_64.rpm

DO NOT try and install it
Go to where ever you have downloaded it to
rpm2cpio ./lib*.rpm | cpio -idmv

As root go to the usr/lib64 directory it will create
cp libcurl* /opt/google/earth/pro/

Regards

Mal

This works perfectly, Raistlin, thank you.

I’ve installed the official RPM with --nodeps switch to ignore the mesa-libGLU dependency, as I alreayd have installed libGLU1. Then, force-copying this libcurl version to Google Earth’s directory allowed the application to start up and work correctly :slight_smile:

1 Like
  1. This is NOT the Spanish part of the forums. Please go to Español (Spanish) - openSUSE Forums .

  2. This is an old thread. When you have a problem, please start a new thread (of course in the proper language part).

1 Like

Thank you very much I already did it like this, in opensuse tumbleweed with XFCE.

@francayopapagallo Hi and welcome to the Forum :smile:

Maybe a graphics card issue? I’m on Nvidia and it’s working fine for me.

Perhaps some system information;

inxi -SMGxz
1 Like

Using nvidea or ati-amd video card that had not happened to me, but using integrated video intel HD3000 it was different, perhaps some library was missing to make better use of Mesa. Luckily I already got here the solution mentioned above.
google earth

@francayopapagallo I suspect it would be Intel/Mesa. But the libcurl item is not needed?

ldd /opt/google/earth/pro/googleearth-bin | grep *curl*

I suppose they must play their fundamental role when google earth started, but when I installed google earth and copied and pasted libcurl.so.4 and libcurl.so.4.6.0 it was still the same (without starting), it was when I installed libGLU1 that it started.