Google Chrome Default browser

Trying to make this browser default has been a failure.

latest and greatest Kde, Tumbleweed and Google Chrome.

Starting it from Konsole get kwallet error’s

I can click the default browser button forever for nothing, went into Configure desktop> Personalization> Applications> Default Applications> Web Browser> Select, /usr/bin/google-chrome-stable %U

I do not have Firefox.

google-chrome             
[12507:12529:0815/004209:ERROR:native_backend_kwallet_x.cc(1029)] Error obtaining KWalle
t handle


When you launch Chrome for the first time, it should prompt you to make it your default web browser.

Also, wondering how/where you installed chrome from?
You may want to remove your existing Chrome.

If you run the following from a root console, you should be able to install the latest Chrome, part way through the install you will be prompted to verify a key, it’s a well known error by the Chrome developers. Choose to “Ignore” (i) the error.

zypper in https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm

After installation,
On most Desktops you should immediately be able to open the menu item to launch Chrome.
Internet > Chrome

If you are running KDE, you should also be prompted to store your Chrome passwords in KDE wallet, but it will be a normal GUI window you can enter your selections, not an error you can’t avoid.

TSU

I cannot offer a solution, but I can confirm the problem. Recently installed Chrome on a fresh Tumbleweed, using Google’s repo. I’m running Gnome, and it is not possible to set Chrome as default browser. All changes in mimeapps.list, xdg-settings, etc. are dismissed out of hand. Chrome keeps asking every time I open it. Might be a bug in xdg-utils. However, this should affect a great number of users.

[https://www.google.com/linuxrepositories/

Used CLI for rpm](https://www.google.com/linuxrepositories/)

I will be the first to post a fix when i figure it out, fighting with this for a long time:)

Thought i had but no go, however i think we are closer than before.

https://productforums.google.com/forum/#!topic/chrome/qmoczzPPzLQ

Well it turns out xdg can be used via bash

linuxbeastmaster@jerico:~> xdg-settings set default-web-browser google-chrome.desktop
linuxbeastmaster@jerico:~> xdg-settings { --help
xdg-settings ? get various settings from the desktop environment

Synopsis
 
xdg-settings { get | check | set } {property} [subproperty] [value]

xdg-settings { --help | --list | --manual | --version }

Use 'man xdg-settings' or 'xdg-settings --manual' for additional info.
linuxbeastmaster@jerico:~> xdg-settings get default-web-browser
google-chrome.desktop
linuxbeastmaster@jerico:~> 


This suggests chrome is default

That’s odd. For me xdg-settings has no effect.

$ xdg-settings set default-web-browser google-chrome.desktop
$ xdg-settings get default-web-browser firefox.desktop

Just to rule this possibility out: what happens if you try
xdg-settings set default-web-browser firefox.desktop
?

I found this workaround: starting google-chrome-stable --no-default-browser-check seems to skip the check.
Therefore:

cp /usr/share/applications/google-chrome.desktop ~/.local/share/applications/

Then edit this file in .local/share/applications/ and append behind every Exec=/usr/bin/google-chrome-stable the option --no-default-browser-check

This should work after the next login.

This is becoming a wealth of awesome information, keep it coming:)

Decided to take a closer look at this…

I don’t know how you guys are even able to install Chrome,
I’m throwing an error that doesn’t seem to be resolved easily (I haven’t seen this problem in other versions of openSUSE, this may be unique to TW)

The following describes adding the repo, refreshing and then attempting to install Google Chrome browser on a brand new Tumbleweed (Snapshot20160815)

# zypper ar http://dl.google.com/linux/chrome/rpm/stable/x86_64/ Google_Chrome_Browser
Adding repository 'Google_Chrome_Browser' ................................[done]
Repository 'Google_Chrome_Browser' successfully added
Enabled     : Yes                                                 
Autorefresh : No                                                  
GPG Check   : Yes                                                 
Priority    : 99                                                  
URI         : http://dl.google.com/linux/chrome/rpm/stable/x86_64/


# zypper ref
Retrieving repository 'Google_Chrome_Browser' metadata ...................[done]
Building repository 'Google_Chrome_Browser' cache ........................[done]
Repository 'openSUSE-Tumbleweed-Non-Oss' is up to date.                         
Repository 'openSUSE-Tumbleweed-Update' is up to date.                          
All repositories have been refreshed.

# zypper se chrome
Loading repository data...
Reading installed packages...


S | Name                   | Summary                  | Type   
--+------------------------+--------------------------+--------
  | google-chrome-beta     | Google Chrome (beta)     | package
  | google-chrome-stable   | Google Chrome            | package
  | google-chrome-unstable | Google Chrome (unstable) | package
# zypper in google-chrome-stable
Loading repository data...
Reading installed packages...
Resolving package dependencies...


Problem: nothing provides libgconf-2.so.4()(64bit) needed by google-chrome-stable-52.0.2743.116-1.x86_64
 Solution 1: do not install google-chrome-stable-52.0.2743.116-1.x86_64
 Solution 2: break google-chrome-stable-52.0.2743.116-1.x86_64 by ignoring some of its dependencies


Choose from above solutions by number or cancel [1/2/c] (c): c

This missing dependency doesn’t appear to be trivial… It’s not in existing openSUSE repos (that I’ve been able to find), It can be found using rpmfind and pbone, but it seems that additional dependencies are triggered which can make for a difficult process of finding and installing files one by one.

TSU

Amazing, I’ve literally done everything could think of without success!

Destroyed my OS in the process, thanks to Snapper were back after shear disaster.

Chromes buggy proprietary parts do nothing but taint the system, Some things i cannot just let go, have to have it.

Has anyone figured out how to set Chrome as the default browser… OpenSUSE Tumbleweed

Thanks!

From the way it’s working I’d say: Yes, me has it working.
The entry I have in systemsettings is plain “google-chrome”

Knurpht what steps did you take o install chrome?:slight_smile:

Please include your operating system and desktop environment.

Good news: I think I found a real workaround!

I kept playing with xdg-settings set default-web-browser. I was able to set all .desktop files I tried as default-web-browser, even little shell scripts with no meaning. At some point I figured it out: xdg-settings doesn’t handle the hyphen correctly! Therefore I made a local copy of google-chrome.desktop:

cp /usr/share/applications/google-chrome.desktop ~/.local/share/applications/google_chrome.desktop

IMPORTANT: note the underscore in the destination name!

Now I’m able to set

xdg-settings set default-web-browser google_chrome.desktop

Only down side (so far) is that there are two non-identical .desktop files (the original still resides in /usr/share/applications/ and is likely to be overridden when upgrading Chrome), so Google Chrome will show up twice in the application menu. Just use the correct one.

Please let me know if it’s working for you!

Downloaded the rpm from it’s website, changed to the dir where I downloaded it and did


su -c 'zypper in ./downloaded_rpm_name_here'

At running ‘zypper ref’ I trusted the key for the repo added by the rpm.

EDIT: Done like this on all openSUSE versions that would support running Chrome.

Your general procedure has worked for me on all openSUSE until I tried to install into TW last week (see my previous post) and found missing dependencies which would be hard to provide.

TSU

This command hung for a good 10 min before i ended the session.

So i did

su -c 'zypper in ./downloaded_google-chrome-stable_current_x86_64.rpm

did you mean?

su -c 'zypper in google-chrome-stable_current_x86_64.rpm 

Thanks for helping

You should be able to actually see what is happening and any errors should display if you execute the commands exactly as I posted in my provious post

https://forums.opensuse.org/showthread.php/519428-Google-Chrome-Default-browser?p=2789374#post2789374

The commands I used should automatically try to install the latest stable chrome browser.

TSU

You forgot the closing " ’ " in both cases.