Goodix touchscreen issues


I’m having issues getting a seemingly-new Goodix (Goodix T080642-01D-GTC, with a GT9110P IC) touchscreen to recognize on leap 15.3 or 15.4. It shows in the sysfs:


Udev info:

localhost:/sys/bus/i2c/devices/i2c-GDIX1003:00 # udevadm info /sys/bus/i2c/devices/i2c-GDIX1003:00
P: /devices/pci0000:00/808622C1:05/i2c-5/i2c-GDIX1003:00
L: 0
E: DEVPATH=/devices/pci0000:00/808622C1:05/i2c-5/i2c-GDIX1003:00
E: MODALIAS=acpi:GDIX1003:GDIX1003:

i2c driver doesn’t see it:

localhost:/sys/bus/i2c/devices/i2c-GDIX1003:00 # dmesg | grep i2c
[   11.319839] i2c_designware 808622C1:06: I2C bus managed by PUNIT
[   11.542239] axp20x-i2c i2c-INT33F4:00: AXP20x variant AXP288 found
[   11.782385] axp20x-i2c i2c-INT33F4:00: AXP20X driver loaded

I’ve tried updating the kernel and related packages (extra/optional) and it still isn’t usable. I’ve also manually loaded/relaoded the Goodix/i2c drivers and that doesn’t do anything. Is there just not driver support for this device yet?

There is this block of code in the Goodix driver:

static const struct acpi_device_id goodix_acpi_match[] = {
{ "GDIX1001", 0 },
{ "GDIX1002", 0 },
{ }

And there isn’t a GDIX1003 listed.

Any help would be greatly appreciated and I can provide more info if needed. Thanks!

Would be good to try using Tumbleweed as that has the newest kernel and drivers.

For that you do not need to install Tumbleweed, just run it from an USB stick.

No good on Tumbleweed either unfortunately. I’m guessing this is too new of a device.

Your bugreport?

ION tablets are such a corner use case (with limited old hardware) that it would be a wonder if it works out of the box with a full standard desktop operating system…

Yeah it’s my report. They worked great until this new batch with the new touch controller. And yeah it’s definitely a weird unit and I was surprised to get it working, but we needed “8 inch rugged” tablets that are also affordable so this was one we went with, plus we had worked with them before. All we do really is load a kiosk web browser on boot. I wouldn’t be surprised if the GDIX1003 started showing up in more and more hardware though, as these were fresh from Taiwan.

What’s really ridiculous with these is that they originally came with a 800x1280 portrait resolution display so GRUB and Plymouth are sideways compared to the OS. Funny that my Steam Deck does the same type of display rotation post-boot going from “Gaming mode” into “Desktop Mode.”