Good 'ol ATI video not working (still)


Sapphire Radeon 3650, Gigabyte ga-ma770-ds3 mobo, acer al2216w monitor.

Installed the 1-click from opensuse community… no go.
Installed ati 8.503 (new one on 18th)…choppy and still says messa for opengl in ati control (after aticonfig etc)

opensuse 11 looks good…but…

any help is good help!


might be a good idea to post xorg.conf

ahh… should have…

Section “ServerLayout”
Identifier “aticonfig Layout”
Screen 0 “aticonfig-Screen[0]-0” 0 0

Section “Files”

Section “Module”

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:0:0”

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24

eh voila!!

After rebooting and installing the driver, run the following in a terminal window (better yet, in an xterm session):

sudo sax2 -m -r 0=fglrx

then reboot.

There is a bug in how the driver interacts with Sax2 (it was present in the 8.4 drivers with 10.2, and is still present); the above workaround forces 3D (including AIGLX support) active and to screen 0. In fact, the 8.5 Catalysts are working better with 11.0 GM than they did with 11.0 RC1 patched to GM, and those worked best of all.

thanks a bunch!!

did sax2 -m -r 0=fglrx
output =

SaX: initializing please wait…
SaX: your current configuration will not be read in

SaX: wrong module syntax
SaX: syntax: -m CardNr=CardModule ,…]

so I did it without -m (not too sure what it does)
sax popped up with 3d config etc… going to reboot to see…

hmmm… didn’t work…
Well… sax says its ATI ATI Radeon HD 3600 Series (RV635 9598)
Activate 3d Acc is checked

When moving windows its very choppy

glxgears runs… 2120 frames in 5.0 seconds = 423.842 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0.0”
after 11565 requests (37 known processed) with 0 events remaining.

Running kde 4 … no special changes…

Let me know if I can paste anything to help out!

I restarted the process again.
(tried to get 8.5 again b/c it worked in RC1 but amd’s link is dead)
8.6 installed, aticonfiged it and then saxed it with fglrx. Sax popped up and then instead of just save I tested it. Crash!! Black screen and had to hard reboot.
Booted then ati cont centre and it says mesa for opengl


I just shutdown and I got a sys(something or other) error 11 and it went to text mode …could be run level 3 (but I’m no linux expert… just trying to get away from Smindows)

Anyone help me???

hmmm… just tried Ubuntu…works perfectly…
don’t want to switch distros :frowning:
Anyone help me out?

Hm, of curiosity I tried the one-click at this address:
On my system, an XPRESS1250, it installed a debug version
of the kernelmodule, which of course broke my configuration
totally. So I suggest you return to the radeonhd driver and
then use yast to uninstall everything related to fglrx, a
reboot ater having done that might be a good idea too. Btw
the installer also installed the debug kernel, if you don’t
need it uninstall that too. Having rebooted to your new setup
use yast and install the ati driver from the ati repo, that’s
certainly the best way to get it working.
Run aticonfig --initial, reboot into runlevel 3 and run
sax2 -r, that should do it.

Go into the yast repo manager, select Add and add from the community repos. Choose the ati repository. Remove your current fglrx driver and install the one in the ati repo. Reboot.

If after rebooting, mesa is still used, do:

init 3
sax2 -r -m 0=fglrx

If the sax2 line gives you the same error as before, then just use sax2 without any of the other options.

I have the same problems with the onboardcard Ati x1200 an the mainboard Asus m2a-vm. I use suse 10.3 and have the warning >>>>WARNING: could not find /usr/src/kernel-modules/fglrx/.libfglrx_ip.a.GCC4.cmd for /usr/src/kernel-modules/fglrx/libfglrx_ip.a.GCC4
CC /usr/src/kernel-modules/fglrx/fglrx.mod.o<<<<<<
after >>>fglrx-kernel-build<<<
and wen i used sax: sax2 -m -r 0=fglrx
output =

SaX: initializing please wait…
SaX: your current configuration will not be read in

please help

to mtpmoni:
I have the same motherboard and have had it working in 10.3
and now in 11.0, so have hope. My guess is that you don’t have
the kernel development packages installed. Goto yast>software>
software management, select patterns in the filter dropdown
box, scroll down to the development section and mark the
linux kernel development entry for installation and click
accept. That finished reinstall the ati drivers using the
ati repo and rerun the sax setup.

Over at Packages, FAQ’s, and How-To’s - Compiz Community Forums, djdoo has been posting his experiences with ATI video card setup, particularly xorg.conf parameters, for the past six months. Worth a look.