Gnuplot driving me crazy in suse 11.3, is it bugged?

Hello all,
I’m dealing with a very nasty problem in gnuplot (default version from repos + patched from gnuplot site).

the command

set style line 1 +options options options *

does not work!
I mean, the settings are changed, but when it comes to the plotting, it does not change the line style. No matter what terminal I set (I’ve tried both PNG and postscript EPS), it DOES NOT change the line style.

Even though gnuplot prompt informs me that the options are changed:

$gnuplot> show style line

linestyle 1, linetype 3 linecolor rgb “black” linewidth 3.000 pointtype 3 pointsize 4.000 pointinterval 0

can somebody help me, please? I need to finish my Master’s dissertation and all graphics depends on gnuplot. Snif.

Can you post a gnuplot file (or a link to one) that shows this problem?

It might be easier for someone to help you.

hi, here is the code


reset
set terminal png enhanced  size 500,160 font "Helvetica" 9
set output "k_enh_buoy_feb2002.png"
set xlabel "Tempo (dias)"
set yrange [0.98:1.22]
set ytics 0.98,0.04,1.22
set mytics 3
set timefmt "%Y/%m/%d	%H:%M:%S" 
set format x "%d/%b"
set xdata time

set style line 1 lt 2 lw 3 lc rgb "black"

plot "2001/02/01":"2001/02/08"] "co2out_1b_nohd.txt" using 1:8 notitle w l

pay attention to the line stating

set style line 1 lt 2 lw 3 lc rgb “black”

I won’t put the data, so you can check it using functions like sin/cos…

I’ve tried this code in 3 different computers using suse 11.2 & 11.3 and the line style DOES NOT CHANGE. It doesn’t matter which terminal I select, if the terminal is BW only, the line width doesn’t change, if it is colored, neither option changes. I never had such problems before.

As I haven’t had access to other linux boxes these days, I wasn’t able to test it in other distros…

The following simple file works for me (openSUSE 11.3)


reset
set terminal postscript enhanced eps "Helvetica" 9
set size 1.0,0.5
set output "k_enh_buoy_feb2002.ps"
set style line 1 lt 1 lw 5.0 lc rgb "blue"
set style line 2 lt 3 lw 5.0 lc rgb "red"
plot sin(x) with lines ls 1,\
     cos(x) with lines ls 2

Observations:
(1) I think you need to use the linestyle command (ls) in the plot line.

(2) The “size 500,160” argument you had in the original terminal command seems to interfere. I found that the color changed, but not the linewidths.

(3) I haven’t tried this with other terminals.

I don’t know enough to say if these are bugs or expected behavior, but that is what I found.

Hopefully that helps.

well, well, well.
It worked!

the addition of ls 1 in the plot line did the trick. But, I’ve been using gnuplot for years now, and never heard of such option. Where did it come from? have any clues?

thanks and bye!

draconar wrote:

>
> well, well, well.
> It worked!
>
> the addition of -ls 1- in the -plot- line did the trick. But, I’ve been
> using gnuplot for years now, and never heard of such option. Where did
> it come from? have any clues?
>
> thanks and bye!

Not sure. I’d not used line styles like that before (I had always put all
of the options directly on the plot line before) so I learned something
here.

Anyways glad you got it working. gnuplot is a fantastic program.


Don

Hi,I can’t Find the gnuplot for suse 11.3 to install there!!
can you help me?
when I type “gnuplot” in the terminal it’s write:

If ‘gnuplot’ is not a typo you can use command-not-found to lookup the package that contains it, like this:
cnf gnuplot

what should I do ?
can you give me the package of gnuplot for suse 11.3 ?

regards.

11.3 is end of life, like ages ago…
So is this thread.

for 32 bit: http://ftp5.gwdg.de/pub/linux/suse/opensuse/discontinued/distribution/11.3/repo/oss/suse/i586/gnuplot-4.4.0-3.18.i586.rpm

for 64 bit: http://ftp5.gwdg.de/pub/linux/suse/opensuse/discontinued/distribution/11.3/repo/oss/suse/x86_64/gnuplot-4.4.0-3.18.x86_64.rpm

On 2013-10-24 17:56, kamgh wrote:
>
> Hi,I can’t Find the gnuplot for suse 11.3 to install there!!

Well, not surprising, as 11.3 is too old and repositories may have been
deleted on servers. You have to install something modern, like 12.3.

> can you help me?
> when I type “gnuplot” in the terminal it’s write:
>
> If ‘gnuplot’ is not a typo you can use command-not-found to lookup the
> package that contains it, like this:
> cnf gnuplot
>
> what should I do ?
> can you give me the package of gnuplot for suse 11.3 ?

IF you were using a current openSUSE version, notice that it is
telling you to run “cnf gnuplot” as that command will give you the
answer to your question.

But not for 11.3. it will probably not work any longer.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))