Gnomes cpufreq-applet

Hello everyone,

The problem I’m having is the cpufreq applet is always set to “ondemand”, and I would like to be able to set it myself.

I have been looking around on the opensuse forums, and the only thing I have seen is one other person having the same problem.

I have read into this on various other sites and the solution seems to be to set the suid of cpufreq-selector. On ubuntu for example you achieve this by running:

sudo dpkg-reconfigure gnome-applets


I’m trying to figure out how to get this to work in opensuse by setting the suid via command line, but I’m not familier with how to do this yet. I’m looking at a post in the how-to section at, but am hesitant to do anything as I may mess something up and break opensuse on my laptop.

I’m also aware of the security risks associated with this, as they are very well stated on the opensuse lists and in other places on the web.

If anyone would be willing to help, it would be greatly appreciated.

Thank you,

Nevermind, I figured it out.

I’ll post a how-to

Where can we see that how-to?

I found a way to change that via the command line, but it is not convenient + it requires root rights.