Gnome went bye bye

Hi guys

I’m pretty new to opensuse (one week), it’s my first “adventure” in linux. Although my work is based still on the windows thing (manly because of decent CAAD software in linux), I’m loving the speed of my 64bit open suse, that I was able (at cost) to install on a partition. Well, needless to say that I know nothing about linux, I can barely move myself in the terminal using the most basic commands.

here is the problem. I’ve tried to install compiz, and … due to my own stupidity, I ignored a warning that said that some issues would have to be fixed manually…
To cut the story short, it messed up my gnome, I can’t access Yast… says that some Libs64 … are missing… no network too, the drills…

here goes my questions:
is there a reasonable way of fixing this with without having to reinstall the system ?

if re-installing is recommended, is there a special dvd or installation mode recommended ?

thanks guys, I really appreciate any input


If you have a DVD you can repair your install iwith it, when booting off the dvd just choose automatic repair, if it won’t work then come back here and report what is still wrong.

Here come the input:
My suggestion is to log in to Gnome, open the terminal and type

zypper verify

if there are any packages inconsistencies this command will report it.

Guys, first of all thank you for taking a bit of your time to answer.

The zypper verify, outputed a error of a sort. (sorry guys, it’s pretty much Chinese to me)
when accessing network,a bunch of errors appeared like: failed to execute child process"/usr/lib64/gvfs/gvfsd_network "
the same after the yast password… a bunch of lib64 errors.

I though it might be something with the lib64 folder and the files in it. or missing, misplaced or simply corrupted… beats me!

I tried a recovery from the dvd , also failed… but i believe it was my fault because i didn’t allowed linux to mount point on my win partitions (just in case !!!) :slight_smile:
then, i re-installed the thing, on top of my linux partition, and pretty much installed itself. this time I went KDE… lets see how it goes. I hope to be able to change it to gnome if needs be…

All is working, i just lost some desktops and a few bookmarks. All is good.

again thanks for the help, appreciated


Next time if you can reach the console at least, just type

zypper verify

if it returns any error messages the

zypper up

probably installs you the missing packages.
In the other case - if there are no error messages from zypper verify - start the repair from the DVD.
Good luck.