Gnome system menu overlaps with added themes

Hi all,

I have been trying to customize my gnome DE for a bit now, and am struggling.

My current issue is that the system menu seems to maintain the default theme, and add my selected theme on top.

The example shown here is the BottleGlass theme I found from I am not married to this theme, and will probably end up changing it, but this is a consistent enough problem that it felt time to post.

I have looked at the GNOME manual, but it seems woefully out of date. I have also done a lot of searching, and cannot find anybody with the same issue.

How can I make my system menu take on the theme I select without overlapping like this?

As an aside, does anybody have any frosted glass type themes for gnome they would reccommend?

@OrangePulse Hi, the theme might be too old (38 series)… you need a theme that supports GNOME 46.x but many things are hard coded into GNOME now…

Edit: I’m assuming you did install the user-theme extension?

I did install the user-theme extension. I can use Tweaks to apply the theme to some windows without having to enable user-themes, but I have yet to get any themes to actually stick to the main programs (system menu, drop-down calendar, file explorer, etc.).

The example above specifically only happens when I do have user-themes enabled. Otherwise it is just the default background.

I dropped mint + cinnamon partially because I was really tired of the ugly flat-everything aesthetics. More than anything I just want a frosted glass look on my windows, file manager background, etc.

I really adore Gnome’s workflow and general layout, and want to make it work. I did not realize how difficult this would be, and I am a little heartbroken over it.

Apologies for my earlier distress.

Turns out there was a big confusion on my part regarding Shell themes vs GTK themes!

Once I knew which was which and what to look for, I was able to work things out quite nicely!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.