GNOME on X, forgetting screen setting after reboot (Dual screen)

I have dual screen setting on my Dell Optiplex 3020. Decided to leave KDE and give gnome a try.
I have one screen connected thru DP->HDMI connector (I want that to be main screen) and second one on VGA. Until login prompt everything is ok, my hdmi screen is main one. System don’t see resolution good for VGA screen (on wayland too).
So I found a fix for that. I use:

xrandr --newmode “1440x900_60.00” 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync
xrandr --addmode VGA-1 1440x900_60.00

Seems to work good but… After I restart my PC my VGA screen becomes main screen (I don’t want that) and resolution is back to 1024x768. What’s wrong?

Please show us output from

inxi -Gxx

run in Konsole, Gnome Terminal or Xterm. Also upload /var/log/Xorg.0.log to any of these:
Using the susepaste command makes uploading easy.

How are you starting your Gnome session? From GDM? SDDM? LightDM? Startx?

Is 1440x900 the native mode of a connected display?

xrandr commands don’t stick from session to session. You could put them in a script in /etc/X11/xinit/xinitrc.d/ to have them run at each X startup.

You need to set your screen setup via Settings (Menu top right, spanner/screwdriver) → Devices → Display. here you can configure the primary screen, resolution etc…