Gnome no longer starts after update (SuSE 11.3/ATI Graphics)


since the last SuSE online update (last Wednesday?) the X server no longer starts on our notebook (ATI HD 4200) so we only have the consoles available, which limits the WAF heavily ;). We were using SuSE 11.3 with the Gnome desktop for about one months and it worked smoothly, but since the update (which included a kernel update to the X server tries to start 5 times and then gives up. All logfiles end with:

    13.899] Segmentation fault at address 0x3c
Fatal server error:
    13.899] Caught signal 11 (Segmentation fault). Server aborting
Please consult the The X.Org Foundation support 
 for help. 
    13.899] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    14.216] (EE) fglrx(0): firegl_SetSuspendResumeState FAILED -9.

In /var/log/gdm/0.log I also found:

0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x48daf8]
1: /usr/bin/Xorg (0x400000+0x6ae89) [0x46ae89]
2: /lib64/ (0x7f3a1f2d7000+0x32a60) [0x7f3a1f309a60]
3: /usr/lib64/xorg/modules/drivers/ (atiddxDisplayViewportCallbackSetMode+0x6d8) [0x7f3a1d1ed788]
4: /usr/lib64/xorg/modules/drivers/ (amd_xserver17_xf86CrtcSetModeTransform+0x212) [0x7f3a1d5c4cc2]
5: /usr/lib64/xorg/modules/drivers/ (amd_xserver17_xf86SetDesiredModes+0x1cb) [0x7f3a1d5c6e0b]
6: /usr/lib64/xorg/modules/drivers/ (amd_xf86SetDesiredModes+0xd) [0x7f3a1d1f315d]
7: /usr/lib64/xorg/modules/drivers/ (atiddxDisplayScrnInit+0xa7) [0x7f3a1d1e9ac7]
8: /usr/lib64/xorg/modules/drivers/ (atiddxScreenInit+0x805) [0x7f3a1d1c5d45]
9: /usr/bin/Xorg (AddScreen+0x19d) [0x440f8d]
10: /usr/bin/Xorg (InitOutput+0x217) [0x474be7]
11: /usr/bin/Xorg (0x400000+0x25d95) [0x425d95]
12: /lib64/ (__libc_start_main+0xfd) [0x7f3a1f2f5b7d]
13: /usr/bin/Xorg (0x400000+0x25af9) [0x425af9]
Segmentation fault at address 0x3c

I used the ati driver ati-fglrxG02-kmp-desktop, version 8.762_k2.6.34.0_12-31.1 from
the ATI Suse repository.
To solve the problem I already switched to the Xorg driver which lead to a color distorted display but no segmentation fault. But I’d like to get the ati driver running again.

Any ideas? Should I provide some more information?
Any help appreciated. Thanks.
Uwe and Rosi.

Sorry, I forgot to mention that it’s 64 Bit.

I don’t know the reason why fglrx from the repo segfaults. Something you can try from the console is to install the latest driver version with the atiupgrade script. It would deinstall the one you have, download all required packages - such as compiler and kernel headers - create a package in the /tmp directory and install it (which includes compiling the kernel module). The script and explanations are in this post: Upgrading ATI driver with atiupgrade . Tough that doesn’t explain why your current driver doesn’t work anymore and it might not be the answer you expected. Maybe wait until I update the kernel myself … which I’m going to do right now.

  • Oh, we have for a while already (I thought there were a new kernel patch) . Both drivers should work then.

@please_try_again: You’re right, the kernel must have been there for quite a while. I assumed the kernel was updates because the modification date of the boot menu was changed, but this does not necessarily indicate a kernel update. However we did not let “YOU” install update automatically, and so maybe on our system the new kernel arrived only at Wednesday…
Nevertheless I’ll try to update the driver with your script in near future.

One thing I found out in the meantime is that the “failsave” kernel configuration boots into the Gnome desktop (with the Xorg driver running with correct colors, but no possibility to change the resolution or multi-display;)). So the problem really seems to be the ati driver from the ATI/SuSE repositories - or some combination with other packages from the last update.

The system is a HP 625 mainstream notebook and build totally from the “standard” SuSE repositories - no experiments so far:). So I wonder if nobody else has similar problems…

OK, some more news:
It seems to be a common problem that kernel updates break the ati driver from the repository. That’s why some people write scripts to adapt the proprietary driver to the current distribution, e.g. please_try_again in the thread mentioned above or Sebastian Siebert.

I just tried the last one, but it does not work in the moment because the ati driver 10.12 download, avalable from ATI/AMD, seems to be broken:

Verifying archive integrity...Error in MD5 checksums: 48c2e8ce1f504f07a0985afe489b26e3 is different from dfc5d2753d97882b67eb453b85ff8dbc

That’s exactly the same error as mentioned e.g in an Ubuntu forum only some hours ago. Of course I tried downloading this with different wget options and via firefox - it makes no difference though.

What for heaven’s sake is wrong here?

Try downloading it through this mirror instead. I don’t think you can download it with wget so you may need to use firefox or another browser to download it: - - online file sharing and storage - download

I have tried it through this mirror and downloaded fine and successfully made an openSUSE 11.3 rpm (sh --buildpkg SuSE/SUSE113-AMD64)

Thanks to ah7013, I finally managed to solve the issue. The mirror contained an installable driver and with the script from Sebastian Siebert I got the ATI driver running again. The only thing I had to do after running the script was

aticonfig --install

Many thanks to all who contributed!

No problem :wink:

Try to unistall moonlight plugin!!!

My script would have done it for you. :wink:

Ooops!!! wrong responce it is not for this thread. Delete it. This post goes here I confused.