Gnome Maps - Mouse Can't Move Map Around On Screen

Gnome Maps - the mouse can’t grab and move the map image around on the screen. The map is non-responsive when I attempt to do this.

I’m not totally green, but I’m not super sophisticated on the command line. I can follow directions, though, if it is kept pretty straight forward.

Thank you so much for your help. I have Tumbleweed set up perfect for me… except for this.

And with vacation season upcoming, I love that maps program for the family’s planning.

fyi - my distrohopper self has found that this is not an issue except for Opensuse. Manjaro, Debian distros, Fedora… all work great.

I am running it in Wayland. It works with Xorg.

I can just switch to Xorg, but it doesn’t address the problem, of course.

Hi
Start with GDK_BACKEND=x11 in your wayland session…


GDK_BACKEND=x11 gnome-maps

Ref: https://gitlab.gnome.org/GNOME/gnome-maps/issues/129 (looks like it’s a mutter issue)

[QUOTE=malcolmlewis;2928091]Hi
Start with GDK_BACKEND=x11 in your wayland session…
QUOTE]

Thanks. That corrects it for a single use, but the long term problem remains.

In my experience only OpenSuse has this issue.

[quote="“iamjiwjr,post:4,topic:139603”]

Hi
Might take a bug report, let me ping my GNOME contacts…

[quote="“malcolmlewis,post:5,topic:139603”]

Thanks for your response.

Re bug report, it’s already been reported. - Bugzilla #1099370 from June 2018.

[quote="“iamjiwjr,post:6,topic:139603”]

Hi
The clutter issue was fixed overnight :wink: https://build.opensuse.org/request/show/778679 not sure how long it will take to cycle through openQA etc…

I played around with OpenSuse Leap 15.2 beta today. Wayland works perfectf in that. Gnome maps and Openweather, both chronically broken in Tumblweed and Leap 15.1, both work perfect.

As for Tumbleweed, still broken. I just can’t see why these two functions work in the environment all around Tumbleweed, but TW never seems to get corrected.

Sigh!

What a mess!

Hi
The fix is pushed and sitting in GNOME next… patience.