Gnome: Keyboard Indicator


I just configured my keyboard to be US International. Now I get the text ‘USA’ in the Notification Area. I never seen this before and I want it gone. I can remove the default USA keyboard configuration and then it’s gone. But after a reboot it’s back again.

Must be a setting I missed?

It’s an applet on the panel? Check in Control Center -> Startup Applications, is there something in there starting it?

I looked there, didn’t see anything with a name that looked like that.

If you right click on the applet, it should give the option to remove, this should delete it from appearing…

Nothing checked in the Keyboard layout options in the Control Center?

I’ve runned against this in the past as well… It happens only if I have two Keyboard Layouts defined, in my case was US English and Portuguese. I defaulted Portuguese and removed the other options and it doesn’t show anymore.

Just open ‘gnome-control-center’ (normal user) hit ‘Keyboard’ option and under layouts remove all the layouts you don’t use and leave just the primary (the one you want to use), and the applet never bugs you again. That’s how I handled the issue.


That’s the weird thing, there is no remove option.

That is what I normally did. But the USA layout keeps returning after deletion, making me have 2 layouts and thus the indicator shows up :s I never had this before and I configured all my previous installs the same.

Run gconf-editor and look around in there to see if it’s still active.