gnome extensions plugin

After the Firefox update I lost ability to install Gnome extensions.
SO I thought I’d add Chrome plugin. Did what the WIki said and went through compiling the extension:

But still extensions do not work. I get :

Native host has exited.

on the extensions page. In the terminal I see this error:

Traceback (most recent call last):
File “/usr/bin/chrome-gnome-shell”, line 20, in <module>
import requests
ImportError: No module named requests

I have no clue why it is not working. What’s worse the make does not have uninstall so I can’t remove this broken plugin (and I have no clue where it spread the files). ANy suggesstions on the fix?

Can confirm that something changed. See
The “old” Gnome integration was apparently disabled, you need to go to and click “Click here to install browser extension”, then allow Firefox to install “Gnome shell integration”.
I have no idea how to remove the broken thing you tried to install, sorry.

Some users have built the chrome-gnome-shell plugin;

Maybe you didn’t compile the schemas?

Look at the %files section on the spec file, should show you where things may have gone…

Hi, this is a bit a bad user experience, installed Leap 42.2, gnome, want to install shell extensions, does not work.

had to install web( ephifany, or how it is called) to install web extensions, but in firefox it does now work.
firefox browser shows
Attempt to postMessage on disconnected port

How can I enable installing web extensions via firefox?

So is the gnome-shell-extension plugin installed (about:plugins)? Is the gnome-shell-browser-plugin package installed.

yes, the package was default installed, did the gnome desktop install, , fist visit on the extension site asked me to install the plugin, plugin installe, even restarted
as mentioned, worked without problems with web (epiphany), but not with firefox

So this is a multi-desktop environment, rather than a pure gnome?

In firefox, backup you bookmarks and then delete ~/.mozilla directory, then restart firefox and go to and there should be a pop to allow and another to remember…

Well, Leap 42.2 Gnome as installed worked, but the Firefox update to version 52.0 changed the cards of the game… so you now need two pieces of SW for the Gnome extensions to work:

  1. the Gnome Shell Integration extension for Firefox (get it from the Firefox extension site or see post #2);
  2. the Chrome-gnome-shell plugin (see post #3): please note that the packages pointed to by Malcolm ask for Gnome 3.22, but choosing the “Break dependency…” option at install they install and work also with the 3.20 Gnome currently on Leap.

BTW, the “Attempt to postMessage on disconnected port” error is due to package no. 2) missing.
Everything OK here after that procedure.

firefox is insane,
and distributions that what to be stable should not ship firefox latest, ubuntu LTS, openSUSE Leap, … just RedHat / CentOS seem to do it right.

Just got a call form my father, 1200 km away, firefox broke google hangout plugin. great.
while such stuff is acceptable for ‘nerds’ this is not acceptable for normal users that need a working system

you never know what breaks after the next firefox update, Leap should ship esr, not doing so is a bug.

What does FF have to do with LEAP??? It is a program not the OS

For what it is worth FF seems fine here but then I run KDE

Want ESR? Here it is
It’s YOUR choice, not a bug, everything OK here on Gnome too.

thanks for the repo link,

this should be in the default installation for something that wants to be stable
but it comes as a ‘unstable’, 3rd party package.
It is not just only my choice, it is also the choice of a distribution what to include
so no need to freak out just because I mention what is obvious, latest firefox is breaking existing installations for its users.
if distributions decides to make this behavior the default for it’s user, than its far from providing a stable desktop experience.
But I guess from a distribution that makes KDE 5 to the default installation choice, this has to be expected :wink:

just tested, installing mozilla/firefox-esr is not just listed as unstable package, it is not well supported, it would also downgrade java to a older, with less fixed issues, version.
so no, this is not my choice, it is as it is, a distribution choice to provide or break a stable user experience, when things like gnoem extensions or googel hangout stop working form one to the other day, this is bad, maybe not for everyone, but for some, and those will say Linux does not work and go Windows or Mac with chrome, this is bad.
But after soon 20 years of Linux usage I know the ‘your choice’ argument enough, so I will not continue to discuss that, but again, thanks for the link

Solved - while I compiled the chrome plugin successfully (which works now in Firefox as well) there were python packages missing. Initially I’ve been confused as pip reported that there is “requests” module, but what I haven’t realized it was python3 requests, while python2 requests was needed.
Later on I found this package thx to Yast :slight_smile: .

Installed the software package for Epiphany web browser (shows as WEB icon in the menus once installed). The GNOME Shell Extensions is a built-in bookmark for Epiphany and I got back all my familiar extensions (yay!). Still won’t work in Firefox and probably won’t until OpenSuse moves to GNOME shell 3.22 from 3.20.

A plus is that having another web browser lets you check web sites that suddenly don’t work in Firefox after one of Mozilla’s updates.