GNOME desktop sometimes gets a blue tinge

Hi folks,

I’m running Tumbleweed (version ID from /etc/os-release is 20200306) on a Thinkpad X1 Carbon and sometimes the desktop will end up with a hint of blue all over it. I don’t know what I’m doing to trigger this behaviour and often I don’t know how to get rid of it either! It seems to be a software thing, as it’ll go away after a while sometimes and I’ve also not had problems running other Linuxes on this machine. Any ideas what this is and how to stop it?


Normal desktop:
Blue tinge:


Hi, welcome to these forums,

From your info I get that you haven’t updated your Tumbleweed. To elminate that it’s something that’s already fixed, run

sudo zypper dup


Hi and welcome to the Forum :slight_smile:
You haven’t set Night Light on via Settings -> Display -> Night Light this would create the ‘blue’ tinge your seeing…

I do have a night light, but it can’t be that - when it happens, if I move the mouse up to “Activities” (top left) the display goes back to normal and when I go back to a window (like the browser window), the blue thing is there again.

I’ll try do an update and see what happens.

Nope, updating didn’t help. In case it’s not obvious from the screenshot, it affects the whole desktop area besides the panel at the top. Still no idea what it is and the only way I can get rid of it is to log out and log back in :/.

That is normal, it’s the GNOME feature for drag to maximize the window, if you drag the window left or right it will use half the screen… Normally if in the window top bar and press the mouse button eg left then it will do this.

Right, thanks. I see I can control it by dragging up, though sometimes I think it gets stuck. Anyway, is there a way to turn it off? I couldn’t find anything in GNOME’s settings and there seem to be fewer options than I’m used to with KDE!

Gnome Tweak Tool -> Windows -> Edge Tiling ‘turn off’