GNOME 46 Not changing the system fonts

I am trying to change the system font but it is not reflecting in TWEAKS please see the screen shot below.

Any solution will be highly appreciate.

@rhussain what do you mean by system font? Or are you referring to a specific application?

I want to change system wide font, as you can see I am changing default font to “Poppins” font for the GUI. But it is not reflecting after restart it show back to default font which I believe “Cantarell” for interface text and Document Text. For terminal I am picking Space Mono but it fall back to “Source Code Pro”.
Poppins and Space Mono available and I installed them.

I hope it will make sense now.

Thank you

@rhussain So are the font’s your wanting to use installed system wide, or in ~/.local/share/fonts directory?

I did not check that. I installed through built in app when you open a font and it asks you to installed. You are absolutely right the font is not present in .local/share/fonts. I will put there and check it.

Thank you

It is ~/.local/share/fonts. And that is in a user’s home directory. Thus only for that user and NOT system wide.

so how can I install system wide? but when I pick from the list while changing it is available. Not sure what I am doing wrong.

Thank you

@rhussain it only needs to be there for the user or do you have multiple users? Try running fc-cache as your user to update. Then logout/login.

The question what you mean with “system wide”? For me that is something that is available/installed/set/configured in the system (of course needing root to do this). Then all users will be able to e.g. use it or have it as a default configuration.

Now I am not a Gnome user, but what I see from your image, that is a configuration tool for a Gnome user to configure/manage her/his Gnome desktop environment. It will only influence that user’s environment. Not of any other Gnome user. And of course not of any other KDE or other DE user. And it will certainly not have impact on the systems configuration. I would not call that “system wide” by any means.

1 Like

I have only one user. I will run the command and try.
Thank you

Just want to let you know, it is a bug in tweak app not the GNOME 46. I was able to change the font with DCONF app. If some one wants to do it, please go to DCONF > ORG> GNOME>DESKTOP>INTERFACE then same steps but change interface to Documents text and same for terminal Monospace font name. It will do the magic.

I found the solution on reddit.
Reddit Solution

Thanks everyone help, I really appreciate.

1 Like

@rhussain So to clarify, of the three listed you wanted to change the Interface font, that does not equate to system font for me, I would have thought the Monospace Text…

1 Like

So what will be consider as system wide fonts? Can you please elaborate further. To me when I change these Interface font, Document font and Monospace font I saw it is replicate every where. I will consider system wide font change, maybe I am wrong.

@rhussain Those are user interface settings/fonts… system means a system font installed in one of the many locations available for them :wink: If you run fc-cache --verbose you can see where it looks for all the fonts both system locations and user locations…

So even via tweaks you could change, but then in dconf-editor the old one was visible?

1 Like

Confirming, Tweaks 46.0 does not save fonts configs, please see: gnome bug report

2 Likes

I have found a solution from here [Solved] How to change GNOME fonts from the terminal / Newbie Corner / Arch Linux Forums

Use gsettings!

To see list of schemas:

gsettings list-schemas | sort

To see keys for a schema:

gsettings list-keys org.gnome.desktop.interface

To set a key:

gsettings set org.gnome.desktop.interface font-name "Sans 10"

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.