GNOME 3.2.1 - Window Management - DUAL Screens - HELP?

Installed, not upgraded, to OS12.1. System: Intel Core 2 Duo, Gallium on AMD RV710, 8GB RAM, 64-bit OS installed.

Getting “adjusted” to the new desktop. I run a lot of virtual machines on VMware vSphere thus I have a lot of windows “tsclient” sessions open at the same time plus other apps; firefox,etc… I can not figure out howto “pin” an application/window to a workspace to the monitor on the “right” hand side. Seems like there is no “workspace” control for the second monitor in a dual monitor config? I know you can move a window to another workspace by right clicking on the application title bar and “move” to another workspace. I can not get workspace management to work on the second monitor. I need to pair like tsclient sessions together on a workspace across the left and right monitor and have them stay paired together when switching to another workspace.


Well, sort of have a temporary workaround. I like the look and feel of GNOME 3 but its more important to me to control what apps and windows are on a workspace on BOTH monitors. So I found this post openSUSE 12.1 GNOME Clean-Up - by wagscat123 - thanks by the way. It sort of make the desktop behave as GNOME 2 did on OS11.4. If anyone has a solution to control window placement on workspace for BOTH monitors I’d be interested as I do like GNOME3.

If I’m understanding your issue correctly, i think this will do what you want: Fix Dual Monitors in GNOME 3 (aka My Workspaces are Broken!) | Greg Cordts’ Blog

Thanks for the reply! That’s my issue. But I still can not get the open application or window to stay or get pinned to a workspace after I move it. The windows just move or jump around to whatever workspace THEY choose after I move them.

I did some testing on my system and learned some interesting things about Gnome 3 & dual monitors. My system has a low-end NVidia mobile graphics and I had the proprietary NVidia drivers installed. Dual-screen mode was pretty wonky. I couldn’t move windows to another workspace at all from the secondary monitor! When things don’t work as expected, I usually suspect the proprietary drivers. I wasn’t disappointed. Once I rolled back to the open source Nouveau driver, things worked as expected. I was able to put windows on the secondary monitor on any workspace of my choosing.

I’m completely unfamiliar with your graphics card – but that is where I would look to solve your problem. Are there various options (open vs. proprietary, for example) for your card? Experiment a little bit and see if changing the driver helps.

OK, after following the thread above I really like the new desktop. Took some getting used to but I can have multiple applications and windows open and can scroll through the workspaces to find the window I need at the moment. On the left monitor you actually see the window for that particular workspace as you scroll through the workspaces, on the right monitor when you activate "workspaces via the super key, some call it the flying window key, all windows for all workspaces appear. If you pay attention when you scroll through the workspaces the tiltebar for the active window on that workspace actually gets highlighted. So if you select that workspace that window becomes active on the right monitor. Thanks again the the link above - it was key for getting a super desktop!