Git push Windows in KDE

Every time I try a git push, it tries to pass my password as my username. How do I change that?

Hi
Have you configured your username?


git config --global user.name "abetterfish"
git config --global user.name

Or in the root location of your git project;


git config user.name "abetterfish"

Yep, neither worked.




http://i.imgur.com/Sj9PM8W.png


Hi
So it’s just wanting the password, since it’s github, have a look here;
https://help.github.com/articles/caching-your-github-password-in-git/

Or look at using ssh for authentication?

No, sorry. It’s using my password as my username, but I will look into using SSH for authentication. Thanks

Hi
Yes, ssh should be a better option anyway :wink:

I found the issue, KDEWallet was trying to pass my password as my username :3