gimp : create image from screenshot


Some time ago I used an option in Gimp to create new image ==> from Screenshot ==> select a region to grab.
Seems that for my normal user this option has disappear.

but if is start gimp from with root then i have still this option

I tested gimp with a new normal user and there also the option “select a region to grab” is not present :\

Any idea what can be the reason why I have this option only with root?
setting or functionality?

Many thanks in advance

On Leap 15.0 the feature is still shown. This is GIMP 2.8.22.

Maybe check against your GIMP version and then file a bug report?

BTW I will never run GIMP as superuser, thus I can not comment on that.

Still shown in Leap 15.0 but apparently doesn’t work (at least here, only a black area shown on Gimp).
Taking a screenshot to the Clipboard and “Create from Clipboard” in GIMP works though.

Indeed I only checked if the functionality (radio button) was there (and it was).

I now tried it out, and choose to grab part of the screen and it shows in GIMP (part of two GIMP windows and wall paper between them, exactly what I grabbed).

So, to repeat, in my installation, it functions as expected.

A few more tests:

  • works in Leap 42.3 KDE
  • option shown but doesn’t work in TW Gnome at least since 201703xxx
    So apparently there is an issue with the Gnome version. Since the OP uses KDE and I’m no KDE-guy I’m going to stand-by.

Works here with Tumbleweed GNOME and x11… might be a wayland issue?

Looks like a KDE problem.
Could be a permission issue.

I tried in KDE and I can confirm that select a region as user is not an option
but as root the option is present.

If I logout from KDE/plasma and use xfce the select a region option is there
as a user and it is working.

Maybe wolfi can help you with this if he has a chance to see this thread.

As it now looks as if the DE might influence this, I want to add that I am using KDE (and it works).

Seems so, works here too with GNOME and x11 in LEAP 15.0 and “ancient” TW from 2017. Sorry cannot comment on current TW.


I’m not using wayland but Xorg. So seems related to kde and tumbleweed :frowning:



many thanks to everybody for their testing with gimp in different DE.
I had already open an incident but though that it was a translation problem because my user was using French.
I have updated the bug with your finding.


You might experiment to see if changing your Display Manager to LightDM makes a difference. From console, as root:

update-alternatives --config default-displaymanager

Got an idea from this post I quoted.
I think the problem is related to kwin.
In xfce, when I am using xfwm4 the option “select a region to grab”, it is there
however if I switch to kwin in xfce the option “select a region to grab” it is not.

When did Spectacle replace KSnapshot? Could that explain the difference between 42.3 and 15.0 for Plasma users?

In Leap 42.1.

Could that explain the difference between 42.3 and 15.0 for Plasma users?


And it actually works fine here on Leap 15.0 (in Plasma).

The OP is using Tumblweed though, which has a newer gimp (2.10 vs. 2.8).
And apparently it tries to get the screenshot from kwin when run in a Plasma session (which is only possible with compositing turned on btw), but seems not to be able to contact it for some reason.