Getting pSX (the ps1 emulator, v1.13) to run on KDE

I’ve got no idea how to run pSX (the playstation 1 emulator pSX emulator) on opensuse 11.1 KDE 4.3 RC. I trued running it from dolphin, but it’s associated with wine (and I don’t think it should be,) so I went to the command line and tried to run it and got this back:

pSX: error while loading shared libraries: cannot open shared object file: No such file or directory

I just downloaded the “linux” version from the site and ran the file “pSX” that comes with it. Does anyone have any experience with pSX and is willing to offer a helping hand?

you shouldn’t need any idea on how to run pSX. it couldn’t be simpler, assuming you actually have the required library it is saying you are missing.

Quite the profound statement, my philosophic compatriot, but running pSX could be much simpler - assuming the openSUSE repo’s have the required library (that’s, “libgtkglext,” for short) it is saying I’m missing…

… Which brings us back to the beginning, again:
Does anyone have any experience running pSX in openSUSE (KDE4) and/or can offer any substantial advice but is also willing to share their knowledge with a poor, puzzled penguin (that’s me!) without any stipulations?

Don’t everyone all reply at the same time, now.

Last bump… Anyone?

How did you install pSX? It sounds like you just downloaded it from the pSX website as a gz file, and then ran the binary in the included file. This does not “install” the program, and can get you caught in “dependancy hell” which is where it appears you are.

If looking for PlayStation emulation and aren’t married to pSX, I suggest you try installing epsxe from the emulator repo instead (or one-click here) and then keep the emulator repository when prompted. Since it’s included in a “standard” repository, you’ll get more responses to your question than if using a program not readily available for opensuse (pSX).

You’ll also need the psx-plugins in order for it to work correctly.

I did just download and run the binary and, apparently, am now stuck in dependency hell … ! I have and am currently using epsxe for my ps1 emulation needs, but the gui looks like crap (I think it may be a WINE app, if I’m not mistaken.) I just want to check out a native linux ps1 emulator, and when I heard pSX was native, I HAD to get it working.

So, while I’m not married to pSX, I would like to get it into the sack for a few regular romps.

Epsxe is a native linux app.

As far as your dependency issue, have you tried installing the gtkglext library through Yast?

Since pSX isn’t part of an OpenSUSE repo, you’ll probably have a lot better luck in getting responses at the pSX forums.

Good luck.