Getting japanese input on US keyboard

I know it is possible, and I have been trying everything I can find, but I can’t seem to get it to work. I went to languages in YaST and enabled Japanese as a second language, and I have tried adding japanese as a secondary keyboard layout under configure desktop-> regional and language settings. I have a little flag in the system tray that I can click to change from US to Japanese, but all that does is change what the punctuation buttons do.

I have been searching and I can’t seem to find any truly helpful information, so any would be greatly appreciated.

YaST deals with the hardware issues. To add a Japanese software keyboard to KDE, go to System Settings>Regional>Keyboard layout and add the Japanese keyboard.

There is something similar in Gnome.

Well I have many software related options in YaST, but like I said I added the japanese keyboard layout already, but it does nothing. I even found the SCIM configuration and everything seems to be set. Nothing seems to do anything different.

There are a few hoops you need to jump through to get Skim / Scim working in KDE4.

Try this new Kimpanel being developed for KDE4
Kimpanel - openSUSE Forums

It may be a little more simple than getting skim to work.
If you follwo the install instructions for kimpanel make sure you aslo install scim-anthy (the Japanese input part)

If you want to get Skim to work - you need to start Skim (not scim) then go itno the configuration and change it to use kconfig rather than the gtk panel

Make sure you have all scim dependencies installed if you want to use skim

scim (can’t remember exactly but has QT in the name)
and also some Japanese fonts

One other thing I forgot to mention.
To get Skim (or scim) to work in Opensuse 11.2 with KDE4 you MUST have your local language set to English _US UTF8
Any other language and you will find some apps where Japanese input will not.

Pain I know - I have submitted a bug on this but not getting a lot of attention.

I don’t know exactly what you are trying to accomplish, but for a simple input in Japanese
I have NEVER touched ‘language setting’ or ‘keyboard layout’ for e-mail and writing a short passage.

(In Japan, keyboards with the US layout are said to be quite common, if not the commonest.)

With the ‘SCIM’ toggled on, the idea is to input a segment using Roman alphabet keys.
With a good input, say, ‘gakkou’ (‘school’) is converted to Hiragana ‘がっこう’ on the spot;
then to convert that to Kanji, select what you think is the correct form among the choices offered, ‘学校’.

To start with, install the following (most if not all should be in the standard repo):
anthy, scim,
‘’ -bridge
‘’ -bridge-gtk
‘’ -input-pad (handy for picking symbols)
‘’ -tables
‘’ -tables-ja.

You should install some Japanese fonts, as well:
ifntjapa, ifntjapb, xfntja, IPA(P){Mincho|Gothic}.
‘Droid’ or ‘Liberation’ fonts are OK.

Like others, I don’t see any need to install ‘skim-’ packages. Regular ‘scim-’ packages are fine.

You may want to subscribe to the repo:
Index of /repositories/M17N/openSUSE_11.2

Here is a gentle introduction to ‘SCIM-Anthy’ input method-engine:
SCIM-anthy: getting started
(A few things may not apply. Ignore Sections 1.1 and 1.2;
openSUSE has those set up for you.)

A Romaji-Kana conversion chart is handy to have around:
Romaji-kana conversion in scim-anthy
(Print this for reference.)

Caution: Turn ‘SCIM’ off when you don’t need it. You’ll learn the lesson,
soon and often enough.


PS There is now an effort to replace ‘SCIM’ with ‘iBUS’. It seems ‘SCIM’ is tied to QT3
or something. At any rate, ‘iBUS’ did not work at all when I tried it some months ago.

You have misunderstood my point in relation to YaST; YaST makes sure the software knows the hardware configuration of your keyboard. It only has a limited role in how the software responds to your keyboard keypresses.

You need to use the relevant settings in KDE or Gnome to get the keyboard to respond differently to your keypresses. I haven’t ever used YaST for this purpose because since 2000 I have used the KDE keyboard settings for an alternative keyboard layout to the one shown on the hardware and I have had no problems.

At least try this option before you dismiss it.

Thank you all, I am going to see if anything makes a difference. Does it make much difference if I am using 11.1 instead of 11.2?

And John, I see what you mean now, I misunderstood what you were saying about YaST. but I have tried the way you describe and I can’t seem to get it to work, but thank you anyways.

O.K., the problem I have is that I can not get scim to turn on. I should be able to press ctrl+space and it should work, but nothing happens, same for shift+space. I am not sure what the problem is, I have everything installed properly. Am I missing something as to how you are supposed to use it?

No I am dumb, I didn’t logout and back in. It works great now, thank you.

1.Press Ctrl-Esc and see if any scim session running
if scim-panel-gtk is running, but no scim symbol in systray, kill scim-panel-gtk, and scim should restart, you can see it in systray.

2.if there’s not any scim running, edit your ~/.profile, add
export INPUT_METHOD=scim-bridge
(if you have scim-bridge installed) or
export INPUT_METHOD=scim

3.Back to step 1

4.If any problems, open a terminal and run following command, see what returns and paste here.

env | grep IM
rpm -qa | grep scim

Not true. I have my language set to English-GB Utf-8, then installed Skim and configured it (right click on system tray icon-> configure).
To type Japanese, simply click on the system tray icon and select “Japanese > Anthy”. Works fine here :slight_smile:

Perhaps English-GB is not included (as teh install choices for Opensuse are Rnglish-US and English_GB) - but there is a confirmed bug that Skim / scim will not work with other English local settings in applications other than QT and GTK apps - such as Openoffice.

If you were to change to a setting such as English-NZ in language settings scim input is lost in X11 apps