Getting a Radeaon HD6570 to work,,,,

Hello Everyone,

I bought a new comp recently. I installed 11.4. It has an Intel graphics chipset on the motherboard that works mostly. The desktop gets really slow or freezes sometimes. I wanted a zippier desktop so I bought a Radeon HD6570 to install to see if this would solve the problem. It has not worked yet. It does not work even with an 11.4 live disk. It doesn’t work with nomodeset or failsafe. This may indicate that it won’t work with the radeonhd driver according to one of the guides I’m reading, since this is what loads in nomodeset from what I understand. I get a cli in every case. If I type kdestart I get the response: $display is not set or cannot connnect to the X server

Quick question though. Can I try to use the cli to start yast and then install the proprietary driver from there using the instructions found here: SDB:ATI drivers - openSUSE? I have not tried this but I assume it can be done. I don’t want to make things worse. Does anyone have any practical experience doing this? Thanks.


I recommend this method: openSUSE Forums - ATI driver with atiupgrade. But even if you use the other one (which looks simpler but is not), reading the article before can’t hurt.

while checking out please_try_again’s recommendation, can you advise if you tried booting with the boot code ‘x11failsafe’ or if you tried selecting the grub boot menu option ‘FailSafe’ ?

Hello everyone,

Thank you for the help. Ok, yes, I did try failsafe. It didn’t work. Using x11failsafe gives me the message that I don’t have a /etc/X11/xorg.conf.install file. I read in one of the guides about this file, and it didn’t seem to matter as it would provide an unsatisfactory solution anyway from what I understood from step 3 ofthis guide. I’m going to follow please_try_again’s instructions and see what happens. And I forgot to add that when I try to boot normally it asks me what mode I want to set it to. Setting it to the correct mode (1600x1200 in this case) doesn’t work. Thank you for the help again.


Ok, I’ve tried the method you set out in the guide for atiupgrade. It stalls because it tells me that the repo PTA is invalid. I’m in run level 3 using the console to install the script. The repo gets added but cannot be refreshed. I also can’t find the repo if I go to its url in my browser (thankfully I have 2 computers in the same room here), though I don’t know that this is definitive about whether it exists or not. Is there supposed to be a space between the final “/” and PTA? I’m putting one in because it’s there in the instructions. Thanks again.


Ok, I got it to work. I’m writing this from the new computer. I downloaded the script off the unixversal site and went that method after the first one didn’t work. However, I now have a little square in my lower right screen corner with the “amd unsupported hardware” written on it. It’s like this one here. Don’t know what that’s about but it isn’t currently a major annoyance. I know the script installed the AMD version of the driver and I have an Intel processor. It’s mostly good now but not as zippy as I’d hoped and expected it to be. Still freezes up sometimes. If you have some suggestions I’d appreciate it because this system is new and isn’t supposed to be sluggish. Thanks for the help.


I assume you are seeing that error because openSUSE-11.4 is not installed yet and you are only booting from a liveCD. If only booting from a liveCD there probably will be no xorg.conf.install file.

Hello oldcpu,

No, I got that when booting from the hard drive. 11.4 was installed. I mentioned the live cd problem because I don’t think I’ve ever run into a system it didn’t work on. I didn’t get a desktop with it, just the cli. However now I I think I’ve solved all the problems though I have rebooted only once. I reinstalled the fglrx driver using yast and now the warning about unsupported hardware is gone. Thanks again.

It’s a similar card to the one on my thread that you were helping me with oldcpu and looks to be the same issue I had, Can’t boot live kde cd or usb on machine with radeon 6870 - Page 2

Subsidiarity you might find that an OpenSuse 12.1 milestone live disk boots to the desktop ok, we tried just about everything to get 11.4 live booting with my radeon hd 6870, thinking that the card might be just ‘too new’ I tried a 12.1 milestone 3 live disk and the problem didn’t exist there.

Your radeon version is only slightly below mine and it seems cards like ours might be better supported when OpenSuse 12.1 comes out in a few months, expected release date is november 10th

In fact, when the model of the graphics card is too recent, you get that message that the hardware is not supported “watermarked” on the display. However it works because newer cards will normally use the same driver. That’s why I fail to understand how the OP solved the problem by reinstalling the driver using YaST, because the prebuilt package you can install from this repo Index of /mirror/ati/openSUSE_11.4 or the one you can build with atiupgrade are the same driver. But the one you would install from the ATI repo is often outdated and would be more likely to complain about newer models.

No matter how, I’m glad you solved it.